Lost/Unsaved file

Hello I was using Adacity and recorded a audio file. After I finished the recording I went to save the file. I normally jsut save it and it ends up in the audio folder as a .wav with all my other precious files. However, this time when I went to save it I got the prompt that it saved and everything as normal. I then closed the problem but when I went to the audio folder it wasn’t there with all the other files. It is completely missing and no where to be found. I checked the KB for recovery and tried all to no avail. Also, Audacity never crashed nor did I ever get an error message of any sort.

Tried all to no avail:
-Checked the File > Recent Files
-Checked the appdata > audacity > Sessiondata and nothing was there. Confirmed that this was the path in preferences too.
-Ran the Audacity Recovery Utility (http://www.mesw.de/audacity/recovery/)

Please help

By the way. I am using :
Windows 10 64bit
Audacity 2.1.3

“Recovery” is for AUP project files/folders, not WAV files.

Just to make sure the file is gone - Search your entire computer for all WAV files (*.WAV) and sort by date/time to find the most recent ones.

I normally jsut save it and it ends up in the audio folder as a .wav with all my other precious files.

File → Save creates an AUP project, not a WAV file. If you want a WAV file (or MP3, etc.), it’s file → Export Audio. I assume you exported, but you said “save”. Is there a chance you have a saved AUP project?

Thanks for the reply. Yes, I meant export instead of save.

I’ve also performed the search as you mentioned and found nothing.

Any other options?

  1. Launch Audacity

  2. Record a couple of seconds, then stop the recording

  3. “File menu > Export Audio” (but do not export - stop at this point)
    Now look to see where Audacity is offering to save the exported file. Audacity should have selected the same location as the last export (provided that the location still exists).
    Make a note of the location, then cancel the export and exit Audacity.

  4. Open your file manager (file explorer) and go to the location that you noted in step 3.

If the file is not there, look in your recycle bin in case you accidentally deleted it.
If you still can’t find it, then my guess is that it didn’t export but you missed seeing the error message.

Hi samuelamj

Did you find a solution to this problem? I ran across the same problem yesterday, and I already tried everything that was suggested so far.

Here is what else I tried:

  • the test wav files I created could not be found using win explorer, VLC, and Cyberlink PowerProducer
  • from within Audacity, if you try to recreate the same wav file and export to the same folder Audacity does see the file and even asks if you want to re-save it. Of course re-saving doesn’t help.
  • from within Audacity, if you navigate to the correct folder to open the wav file, it is not to be found
  • I installed the newest version of Audacity 2.2.1. I think the old version was 2.1.3? After the install all the test wav files I made suddenly appeared and could be seen using all above mentioned applications. However, after a few hours some of them disappeared again.
  • one of the files that can’t be found is still functioning in my Cyberlink video project.

Obviously the files are there but they can’t be viewed. Seems to me to be a weird win10 issue, but I have no clue how to fix it.

Hoping someone out there recognizes the symptoms and has a suggestion.

btw, I am using win10 pro

Best regards, Tony

What is the exact name and location of the file that you have exported?

Hi Steve, thanks so much for the ideas!

File time stamps are correct. But file location seems to be the trouble. I have three wav files saved in two locations, on a two month old Seagate external 2TB drive, and on a 4 year old 1TB WD drive.

When I turned on the computer this morning win explorer found the files intact on both drives. Then I looked from within Audacity and VLC and they could only see one of three files on the Seagate drive, but they saw all of them on the WD drive. Then I copied the files to C:\user\docs\audacity to test and Audacity could see them there, but then it could no longer see the one file it previously saw on the Seagate drive.

So I have a flaky Seagate drive? Maybe there is a tweek?, … back to google.

If you have more ideas I would appreciate. And of course thanks again for the time/location suggestions, at least I have a work around for now.


Are the problem drives external (USB) drives?

There’s a lot of technical detail about USB drives that I don’t know, but as a fluffy guideline, they tend to be more reliable when used for simple file transfer - copying a file from one drive to another. Writing data that is generated by an application can sometimes be a bit precarious, especially if the drive is becoming a bit flaky. When reading files from USB drives, the computer has to maintain an up to date table of what is on the drive. When an application tries to open a file from a USB drive, it does not directly “see” the drive contents, but is looking at a “mount point” in the local file system, which the computer should then connect to the actual file on the external drive. There’s a lot of ways that this can go wrong.

The first thing to check if a USB drive is playing up, is the USB lead and the plug/socket connections at each end.

Overall, USB drives do not give as reliable performance as internal drives. I would always recommend reading / writing with application from / to a local drive, and use the USB drive simply by copying files between the USB and local drive.

If you are using a USB drive to hold important data, it may be worth finding a diagnostic utility to check the drive. There will be some good free utilities available (Google is your friend :wink:)

Hi Steve

Yes the problem drive is Seagate external USB. The other drive mentioned is internal.

Since your last post I “copied” the wav files to the Seagate external drive and now my applications see them from that location.

I ran spinrite on the drive when I bought it, no issues. But I bought the drive for duplicate file backup and for image backups of C drive.

From what you said, it looks like I should check the validation box when I make an image. Or even better, I should save images to the local drive, and copy to the external drive.

Thanks again for your help.