I have been using AUDACITY for about 2 years to batch convert FLAC files to WAV - it was easy! Import (FLAC files)/Audio, Export/Multiple (WAV) . . etc.

Suddenly, AUDACITY will no longer import multiple file choices into separate AUDACITY windows, it puts them into the same window and its a mess.

I reloaded AUDACITY, LAME and FFmpeg, but still the same problem.

I am certain the answer is simple - but I am dazed and confused. Please help.



The “Import” command imports into the current project.
The “Open” command opens a new project.

For “batch” processing, use a “Macro” https://manual.audacityteam.org/man/macros.html
(previously called “Chains”).

Thank you Steve - I will look at using Macros and appreciate your help.

(but previously it was just: choose the FLAC files/Import/Audio, choose convert to WAV and then Export/Multiple files . . . I did not even know there were macros )


I think the Macro world is beyond my feeble skills.

I was just reading the “How to Import CDs” tutorial and it states

“In order to import tracks from an audio CD, you must first usually extract (or “rip”) the tracks to a WAV or AIFF audio file using CD extraction software; then you can import those WAV or AIFF files into Audacity with the usual File > Import > Audio command.”
I already have a folder of FLAC tracks - my question is: why doesn’t the usual “File > Import > Audio command” work like it used to? It used to read the folder of FLAC files (or individually picked with CTL/click) and then on the “File > Import > Audio” command, import each FLAC file into separate AUDACITY windows. I would then process the windows with “Export/multiple” into WAV files.

No more!

What part of that can you not do?

Hi Steve - thanks again for your support. To answer your question:

When I import a single FLAC file, everything works perfectly. When I try and import multiple FLAC files (by CTL/clicking the FLAC files I want) and then File/Import/Audio, the first file imports OK, subsequent files get stuck into the same AUDACITY project window below the first load and get “squished” - they are garbage.

I was reading about “on-demand loading” being withdrawn from 2.3.3 - it says

"In earlier versions of Audacity (2.3.2 and previous) it was possible to reference external uncompressed audio files rather than importing and reading them into the Audacity project. This was quicker and saved space but was rather dangerous . . . "

I just realized that I had recently loaded 2.3.3 and deleted the older version I had (probably 2.3.2). The way I am using Audacity strongly suggests that I am attempting something that no longer works.

If so, may I ask a basic question ’ how do I import a group of FLAC files into a (new) AUDACITY project, then batch processs them? Or could I get a reload of AUDACITY 2.3.2, which worked for me?

Thanks again


How do you mean “squished”? Multiple Flac files import perfectly for me.

I went back and played with several folders, and discovered that AUDACITY did not like several of the FLAC files in some of the folders - perhaps they are corrupted. I also got an error message (appended) that audacity.cfg was “non-writable”. I deleted it.

I then tried to import the files that AUDACITY seemed happy with and things went much better, the only difference being that the File/Import/Audio now stacks all the imported file in one window (project?) instead of opening the overlapping project windows that I was used to in the previous AUDACITY version. I then exported multiple WAVs and everything went perfectly!

Thank you for your help (and patience!) - AUDACITY can hardly be blamed for corrupt files!
ScreenHunter_409 Dec. 20 14.59.jpg
ScreenHunter_408 Dec. 20 14.39.jpg

to batch convert FLAC files to WAV

If I just want to convert files without any editing I use [u]TAudioConverter[/u]. Once you’ve set-up your output format and location it’s just drag, drop, and click, and you can drag-in multiple files or folders to “batch convert”.

…Sometimes I get a “missing DLL” message when starting TAudioConverter but I just click OK and it works fine, and the DLL isn’t really missing. Sometimes I’ll get the message 2 or 3 times in a row (maybe related to the number of CPU cores?) but everything is fine if I ignore it.

Thanks DVDoug! All going well.