losing envelope changes

I’m making changes in a poorly-recorded speech, of 2 kinds: (1) reducing the loudness of certain overloud fricative and aspirated sounds and breath noises, using the envelope tool; & (2) excising certain disfluencies like lip smacks, false starts, ums, urs, and burps using Edit/delete.

Twice now something has happened in Audacity that looks like a forgetting of past envelope changes I’ve made, back several hours, even though I’ve tried to take precautions against losing work. After every editing change, I do “Save Project” (which I assumed would save the change into the project files on disk).

Every several hours I “Save As” the project under a slightly different project name, suffixing “a,b,c,…”. In particular, what happens is that I first notice that, while using the Envelope tool, it’s not responding by creating a control point. I try several times to make a new control point, but it’s “no go”.

I have noticed that at this stage, I can grab the top blue envelope line with the cursor and pull the whole line down horizontally. Then I zoom way out & notice that the last 20 or 30 envelope notches I’ve put in aren’t there, but ones before that time are.

Once I tried exiting Audacity without saving the project, and re-starting it from the latest version on disk, thinking that the weird changes I’d just seen might be in core but the previous changes I’d made & saved would be there on disk. Didn’t work.

I suspect a fat finger problem, but the action itself seems weird: “forget the envelope changes that have been made during the last hour or so, but not the deletions, and save this to disk”. Any help, or suggestions, or explanations? (I’m using Audacity 2.1.1 under MS Windows 7.)

Perhaps you could try the current 2.1.2 release http://audacityteam.org/download/windows, or possibly even 2.1.3-alpha http://wiki.audacityteam.org/wiki/Nightly_Builds. There have been some bug fixes for envelopes since 2.1.1 and there still are some issues with pasting audio containing envelope points.

I don’t know of an issue where the Envelope Tool is non-responsive.

Presumably because the envelope points aren’t there, the amplitude changes aren’t there either?


Thanks for the note. I installed 2.1.2, continued work, and it happened again after an hour or so. I had zoomed out to take a broader look and noticed the envelope changes I’d put in for a long while had vanished. I then saved the project under a slightly different name and got out. When I opened the previously-saved generation of the project, the changes were missing in it, too. So the weird action includes saving the project in addition to deleting the last so-many envelope changes. This time, the deleted changes represented about 1 1/2 or 2 hours’ work. I’ve taken to saving-as the project with a slightly different name more often, say about every 15 minutes, so that if it happened again, I wouldn’t lose as much work, and when I went back & opened the -2 gen version the changes I’d made up until the time I saved this version hadn’t been deleted. So I only lost about 15 minutes’ work, not 2 hours.

Presumably because the envelope points aren’t there, the amplitude changes aren’t there either?

That’s correct. At 1st I thought rendering had been triggered, but that’s not it – the amplitudes were as they were before my changes.

  • Bill F.

I’ve found an important clue to this apparent bug. Looking at a screen view of about 4 sec of the waveform, I see 2 dips in the amplitude envelope on the left part of the screen that I’d previously put in. The cursor is to the right of them, after an intervening word, and when I do edit/paste to paste in a small clip of background that I’d previously copied (to improve the prosodic phrasing), the noise clip appears inserted into the waveform correctly but the 2 envelope dips vanish. When I hit edit/undo paste the waveform goes back to its previous state, with envelope dips and no noise inserted. I can then hit edit/redo paste and edit/undo paste to recycle these actions, with the same results.
So I’ve got a repeatable occurrence of the bug. I’ll probably leave this instantiation of Audacity running, in case it can help in debugging, and execute Audacity again to continue my work using a recent save-as backup file of my project. I’ll try to attach screenshots of before & after the pasting-in, to show the problem exactly. I’d thought of sending a copy of my project to some Audacity guru who might want to dig out this bug, but I’m afraid if Audacity is started on a file holding the project as it is now, this particular occurrence of the problem will go away, since internal state variables like what’s held in temporary memory as a result of a “copy” won’t be saved in the file data structure.
This does look like a genuine bug; would some Audacity guru care to look at it & find a fix? If so, any suggestions on what I should do now to help?

  • Bill F.

Pasting was one issue that could corrupt envelopes. Please try 2.1.3-alpha which is our current code. In 2.1.3-alpha I don’t lose the envelope if I paste near the right edge of a clip containing envelope points, whether the paste contains envelope points or not, but I don’t know your exact steps and these may be critical to the issue.

If you can reproduce the problem in 2.1.3-alpha, please try to boil it down to simple steps 1, 2, 3… for us.

Many thanks.


downloaded 2.1.3, tried it, didn’t solve problem. It’ll be difficult for me to go ahead making subsequent edits in the waveform, because with each of them, I’d have to look back at these envelope dips to see it it killed them. Also, I’m recording the time location of all the changes I make, and if I come back later to make this paste-in, it’ll shift the subsequent time scale relative to my records. So I’m sorta dead in the water here. I may try rendering in all the envelope changes I’ve made so far and see if that is a magic run-around, but I’d rather get the problem fixed.
Simple steps to re-create problem:
(1) load my project WMF_combined_cleaned_1k.aup;
(2) select a segment of background noise @ 5m59.00s, length 0.2s;
(3) do “Edit/copy”;
(4) select the stretch from about 6m00.200s to 6m01.632;
(5) hit “View/zoom to Selection”;
(6) select a slightly smaller stretch, say from 6s00.209s to 6s01.620s (your view now should match the “before” screen grab I sent);
(7) move the cursor to about 6s01.195 and click left, setting the selection point there;
(8) hit “Edit/paste” (your view now should match the “after” screen grab I sent).
Note that the 2 envelope dips, centered @ 6s00.275s and 6s00.854, vanish. You should be able to hit “Edit/undo paste” and “Edit/redo paste” to make the effect disappear and reappear.
If you’re curious, you can hit the green triangle to play back this stretch to hear what it is I’m trying to do.
I’ll try to email my project files to you if you give me an address.

  • Bill F.

Thanks for testing. Could you upload your project to Dropbox or your favourite cloud server and give us the address to download it? You could also try
http://www.sendspace.com .

We need the _data folder as well as the AUP file, both packed into a ZIP file.


I’ve created a zip file that includes the project and the folder of its data files, and have put it into the Dropbox folder that Windows Explorer shows, which Dropbox says automatically “syncs” it. Now I need to get it to you. I’m a novice at Dropbox, and am feeling my way. It looks like I need to create a link to the zip file and email that link to you, but when I get to the part in Dropbox.com where it creates links, it shows some files in my local Dropbox folder but not the zip file that I just put there. Do I need to explicitly upload the file before I create a link to it? And there’s another problem: the zip file is encrypted. I’d like to send the key and the link to you but not broadcast it on this forum; can you send me an email address to send it to? Mine is XXX@XXX if you want to reply privately. - Bill F.

We appreciate your help.

Most users upload unencrypted files to Dropbox or one of the other services I mentioned. I suggest you do that too.


Many thanks for submitting the problem project. I’ve opened a bug report here: http://bugzilla.audacityteam.org/show_bug.cgi?id=1434.

Mix and Render on the track concerned crashes Audacity, but you could select all the track, File > Export Selected Audio… as WAV, import the WAV into your project then delete the problem track. Please let us know if that export renders all your intended envelope points.


Please let us know if that export renders all your intended envelope points.

Do you need me to do this in order to help your debugging efforts? If not, I’d rather just wait until the bug is fixed, then continue on with my original plan of work. - Bill F.

If the envelope points are not rendered correctly in the export that would be helpful to know because that would demonstrate another problem. I don’t see any other way than export and import in the Audacity versions you have to paste where you want in that project and keep the envelope changes.

Alternatively the crash when mixing and rendering that project has been fixed (at least on Windows) so you could get the latest 2.1.3-alpha, render then try to paste.

I would not bank on the envelope points problem being fixed immediately. There are number of problems with envelope points but the problem you found is obscure. It can’t be reproduced by arbitrarily creating a project containing a number of clips containing envelope points then pasting a region that does not contain envelope points.


I’ve finished my project by taking Gale’s advice for a work-around: every so often exporting the track as *.wav, saving the project as a new version with a slightly different name, importing the *.wav file back into the new project version, deleting the old version of the track in the new version of the project. It works, apparently rendering in my envelope changes. Thanks! - Bill F.