Looping causing distortion

Linux Mint Cinammon 19.3 - Audacity 2.2.1 from Mint Software Manager

When I highlight an area in a track and use Shift Spacebar to do the looping the first pass sounds fine but the subsequent passes have a lot of distortion in it. Seems like something must be feeding back into it to make it distorted. I do not have the red Record button pushed.

I don’t understand jack and pulseaudio. I have downloaded both of them but I haven’t launched them recently. I do see that they are loaded processes in the Mint system monitor but the status is shown as Sleep.

Maybe it has something to do with my selections of input and output in Audacity? I don’t know what to choose. Someone has pointed out in another thread that for what I am doing, which is just playing back music and playing along with it on a piano, and not trying to record the piano, I don’t need jack or pulseaudio…

plus another thing; I am running Linux on a laptop. I take the audio out of the 1/8" headphone jack and plug it into the external speaker input of the electric piano so that I can hear the computer audio mixed with the piano’s audio through the piano’s speakers.
I also am using an external monitor and driving it with HDMI output. The monitor has built in speakers and I can select the output of audacity to go through monitor speakers instead of the piano by selecting it. yesterday I found the output setting to do that by accident but I can’t find it again from the pulldown choices in the output selection.
But as mentioned I wouldn’t think I would be getting any feedback distortion if I am not selecting Record.

PulseAudio is installed as the sound system manager in Mint by default.

Jack is not required.

Save the “Audio Device Info” (“Help menu > Diagnostics > Audio Device Info”) somewhere convenient, then attach that file to your reply (see: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1)

here is the audio device info
audio device info from audacity.txt (5 KB)

That looks OK.

Look in “Transport menu > Transport options”

“Software Playthrough” should be off (not selected)
“Overdub” should be on (selected)

I saw that Software Playthrough was on so I deselected it but that didn’t help. Still distorts when it loops. I’ll leave it off.
Overdub was selected and I deselected and that doesn’t make a difference. I’ll leave it on.

Here is a google photos link to 7 sec video showing it.


Weird. :confused: It looks like some sort of strange buffering problem.

Have you tried rebooting your computer?

Do you have any other apps running?

The rate of your audio file (48000 hz) and your project rate (44100 hz) don’t match.
Try changing any of those and that will fix the thing.
That happened to me on previous versions of Audacity (I can’t reproduce the error on 2.4.2). I used to change the audio rate of the file via:

Hope this works for you too

I changed the Project Rate from 44100 to 48000 to match the rate shown in the track and that DID fix it. Thank you that solves the problem.

STRANGE THING though: In the meantime I had copied the files to a flash drive and put them on another laptop running the same version of Mint and Audacity and I see on that second laptop that the files show 48000 on the track and 44100 on the Project Rate and that version does have the distortion problem when I play the loop. So something pretty subtle is going on.

Here is the Device Info file from the second computer that doesn’t show the problem even with different sample rates.

Regardless of this strangeness I am delighted that you guys helped me fix this. Thank you.
device info from laptop without problem.txt (3.63 KB)

I’m happy that worked for you too!

It is weird that the laptop doesn’t show the problem… In my case I believe the reason is because my external and old USB audio card is fixed to 44100. Maybe it is more related with the hardware than the program itself.

I don’t see the problem on my Xubintu laptop either. The “default” sound system (PulseAudio) “should” be able to handle sample rate conversions when required.

It’s possible that PulseAudio may be configured for higher quality sample rate conversion, or shorter buffer times than the hardware can comfortably manage. That could explain why it is able to play without problem the first time, but when it starts the stream for the second time it is not able to start cleanly in the time available (the output buffer length).

Alternatively, it could be a hardware or hardware driver issue as Geolgar suggested.

You “may” be able to work around that by selecting “default” or “Pulse” as the device in Audacity, and then use PulseAudio Volume Control (pavucontrol) to select the USB device.