Looping. Am I missing something?

Okay. Maybe I’m missing some setting somewhere. I can create a loop, but this seems to be missing something rather important, so I’ve got to be missing a setting or something.

First: I can click and drag from the rough start of the loop to the rough end of the loop. Great. That’s fine. But when trying to fine-tune the loop start and stop points, why is there no corresponding line down into the waveform display? I’m hoping that this is just something I’m missing. It’s extremely inefficient and very annoying to have to keep guessing exactly where I’m at on the waveform.

Also, when trying to fine-tune the end of the loop, is there a setting that will have the display automatically bounce back to where I’m working? Again, this is very frustrating.

Hopefully this is just something I’m missing being new to the program. I’ve tried searching this up, but I’m not coming up with any answers. I typically use the forums as a last resort after not being able to find my answers anywhere else.

I do game development and frequently need to create loops for SFX and music cues, so this is something that is extremely important, and I need it to be quick and efficient.



Are you dragging from the timeline…??
You can pick your selection on the tracks directly and drag over several tracks to select them all together. And the lines are down over the tracks.
Then Zoom in for more accuracy and pick sample length down to individual samples.
Then you can click set loop to selection.
Then click thw "enable looping grey button, then click play…ans the selected track portions will be looped.

Perhaps I’m just going about it the wrong way. Unfortunately I’m not at my PC right now. I was clicking and dragging above the track where the looping start/stop indicators were.

In my previous program I’m used to just being able to drag a selection across the waveform, turn on looping and then zoom in on the start and end points to make any fine changes. Once I had what I needed I could just trim the rest out.

Is there a setting to where the waveform display doesn’t follow the playback position indicator? Or at least snaps back to where I was at when I hit the play button?

Again, apologies if this is covered elsewhere, but couldn’t find an answer searching for it.

Thanks again,


Yes, there has been changes as the version are updated. Latest is 3.4.2 and if you click Help Manual the info is there.
Looping does work the way you describe but if you move the selection you may have to …then set loop to selection again
Regards the waveform display passing the playback position… I think you mean Transport…Transport Options…Enable Pinned Playhead…ticked or un-ticked

This topic was automatically closed after 30 days. New replies are no longer allowed.