Live Directed Sessions for Voice Over

Hi Everyone !

I’m wondering if there are any voice over artists out there who use Audacity to do directed sessions with clients via Zoom or Skype and how you make it work to where they can hear your live audio as you’re recording it.

I’m trying to use a sound driver called Blackhole to do a live recording in Audacity and have a client hear it in Zoom for some voice over work.

When I do the audio test in Zoom…Zoom doesn’t pick up my voice in my mic until I hit the record button in Audacity which wouldn’t be such a problem but there is major lag. I’m wondering if you have any pointers.


There are three known techniques for doing audio production with Skype or Zoom.

– The easiest and most straightforward one is get Zoom to record you and the client on Zoom’s servers. If you ask nice, they will provide two different sound tracks, one you and the other them. If you wear headphones during the performance and work in a quiet, echo-free room, your voice should be missing all that internet distortion and actually come out pretty well.

– Wear headphones and park your iPhone on the desk beside you recording your performance with VoiceMemo.

Put the phone flat on the desk and don’t make any noises or shuffle your feet. Transfer the sound file to Audacity for editing.

– The broadcasters do it with a sound mixer, Zoom computer, and a separate recorder. That’s what this is.

The mixer has to have “mix minus” and be a two-channel mixer. Your two computers have to have stereo Line In and Stereo Line Out. This technique has the advantage that it doesn’t matter which chat program you use. Zoom thinks it’s the only software in the world (on the right-hand computer) and won’t interfere with you.

And that’s the problem with trying to do live production with Skype or Zoom. They hate that. Zoom needs to take over your computer to work right. I’m not making that up. It just does it and it doesn’t ask. Even worse, it does a supervisory pass of your computer before it starts, so it may be a slightly different Zoom every time you use it.

There was one producer who managed to force his computer to make a good recording, but they screwed up the Zoom processes so badly that Zoom collapsed the call, peeled off the recording setups and started up again without them.


I can round up sound samples, but not the Zoom recording.

This is the iPhone on the desk.

And this is the full-on mixer and two computers.

This was an engineering test, so the production values and timing suck. Denise sounds OK, right? She’s four time zones away.


A word on the mixer solution. The goal of that experiment was to see how much I could jam into one pass with no editing. So that’s the music track and both Denise and I in the same mix. I could just as easily have put me on the left and Denise on the right, and mix the music in next Thursday.

That’s why the broadcasters like it. Audio production and Zoom are separate and you can do anything you want.


VO here. Not an expert, so treat what follows as the anecdotal end of true.

The only reason to use blackhole at all is so that you can playback takes to the client, right? Otherwise, you could just set your mic/interface as input for both Zoom/Skype and Audacity. The client will hear the live feed and you’ll record just fine*.

But with your current method, you needn’t press record for the client to hear you. Assuming you have software playthrough of input checked under Audacity > prefs > recording, just click where it says Click to Start Monitoring in the input level meter. Provided you have the multi-output device set correctly (and Zoom’s input) the client should hear you. But as you say, terribly distracting latency.

If your interface has a monitor mix knob, you could set it to input monitoring while recording (no latency) then back to output in between takes and suffer the lag while they’re giving feedback.

Another route is to switch the Zoom input mid-session. Direct from your interface to start with, then the Aggregate device/blackhole when you need to playback takes.

*In my experience, Zoom’s noise cancellation/processing doesn’t bleed across into an Audacity recording of my own input. YMMV but it should be easy enough to check how the two play together on your machine.

** I glean from another thread that your mbpro has 4GB RAM. Is that still the case? IMO this is marginal for a down-the-line vo sesh. Many remote sessions use online tools (Source Connect Now, Cleanfeed, Zencastr etc). The engineer sends you a link, to be opened in Chrome. They record at their end but prefer you to record a back-up in your software if poss. I found my ageing macbook struggled to handle running both Chrome and Audacity without noticeable skipping until I upgraded to 8GB RAM. 4GB may be enough for Zoom/Skype + Audacity, not sure.

*** Further gleaning tells me you might be using a Boss pedal instead of an interface…not sure. No idea about that sort of thing.

**** Can’t help with blackhole multi-output/aggregate settings - I no longer have blackhole, but youtube is your friend for this.

Thanks for your thoughts everyone.

Everything would be perfect if it weren’t for the lag. I’m seeing all sorts of settings for latency in Audacity but none of them do anything when I experiment with them.

Audacity has been amazing for me, but it’s looking like for directed sessions I’ll have to use garageband unfortunately unless someone can tell me what I’m doing wrong with the latency settings.

until I hit the record button in Audacity which wouldn’t be such a problem but there is major lag.

I’m going with what I think you said there, but what did you really mean? Who hears the lag? Voice over internet protocol is always going to have some delay. It’s one of the first things to get used to when you go over to Internet phones from your old reliable land-line. Also see: any cellphone. Also see: The Help Desk where the technician is always two words behind you.

A friend of mine is a cyborg. Part man, part machine. He has to maintain a land-line for the connection to his machines. The wackiness and delay of an internet connection isn’t going to do it.

I’m seeing all sorts of settings for latency in Audacity but none of them do anything when I experiment with them.

That’s for overdubbing. Play an existing backing or rhythm track to your headphones while you perform/sing/play a new separate track. If you set that one up just right, the new and the separate backing track will overlay perfectly. If you don’t, one will be ahead of the other. You can totally fix that in Audacity with the Time Shift Tool later, but it’s a pain and it’s easy to fix permanently (until you change Audacity or the computer).

You’re right. That doesn’t do anything for live performance delays.

Post back if you find something that works. This is a forum—users helping each other—not a help desk.


Thank you sir ! I’ll keep experimenting !

No, really. What are you expecting and where is the lag?

As far as I know, you can’t do live production on the internet.

Josh Turner (the overdubbing performer, not the country singer) has a video which seems like four people singing harmony to each other from different cities. What actually happened was Josh created a backing track and shipped it off to the other three performers. They sang overdub sessions to it and shipped the new video and voice files to Josh for melting into one video. They used the internet as a data delivery truck. Not studio space.


Thanks Koz !

I expect the end client to not be hearing my voice in real time since it’s going out across the Internet which isn’t a problem, but what I wasn’t anticipating was hearing my own voice twice. For example, I say a word in real time and then I hear it a half second later in my headphones. Thanks again for your input.

Turn off “Playthrough.”

Audacity > Preferences > Recording > [_]Playthrough (de-select).


WiFi networks can sometimes introduce a 10ms delay or more per end. If you are close enough to your router, consider connecting directly via a cable.

Thanks guys!

I’m too far from the router. If I turn off play thru zoom doesn’t pickup the audio

Zoom doesn’t pick up my voice in my mic until I hit the record button in Audacity

If I turn off play thru zoom doesn’t pickup the audio

So you’re sending Audacity Playthrough to the far side through Zoom. That’s always going to be “one computer late.” Your voice has to go through recording processing and then turn around and go through playback processing.

That’s why in overdubbing, you have to listen to the microphone, MicPre, or interface, not the computer.

Screen Shot 2021-09-06 at 8.54.20 AM.png
That also means, by the way, that the far side is getting a stupid-late voice from you. All those delays adding up. You can go make coffee and your voice will be just then reaching the far side.

This is one way.

Set up a regular Zoom through headphones. Forget the computer recording.

Screen Shot 2020-03-07 at 6.34.01.png
She’s listening to her own voice with her free right ear. The guide or backing track is playing to the muff on her left ear and the video camera (separate recorder) is recording her voice.


There shouldn’t be any need for your Zoom director to hear from Audacity except when you’re playing back a previously recorded take.

This is the sort of thing I’d try. This assumes you have an audio interface and it’s selectable in Audio Midi Settings.

Set up an aggregate device in Audio Midi settings to include your interface and blackhole (checking the box beside blackhole marked Drift Correction). Name the device e.g. Zoom Live VO Input.

Set-up a multi-output device, including blackhole (drift correction checked) and whatever you’re monitoring with - hopefully headphones, so choose External Headphones if they’re plugged into the mac, or your interface if they’re plugged in there (preferable). Name it VO Playback.

In Audacity, select your interface as input as normal, and your new VO Playback device as output (with Software Playthrough of Input unchecked).

In Zoom, select the Zoom Live VO device as input and your interface/external headphones as output.

This way, Zoom should hear you live without (noticeable) lag and hopefully both you and Zoom partner will hear playback from Audacity when you playback a take.

I think that’s the general shape of things but have very possibly missed out a thing or two.

hopefully headphones

That’s required. If you don’t do that, Zoom is going to do echo cancellation, environment suppression and noise reduction. It’s not pretty.

This assumes you have an audio interface

Good point. We don’t know what the microphone is, do we? That might be good to know.