Libavformat.so no longer found after upgrade

Hi! I just updated to Ubuntu 24.04 LTS and Audacity can no longer find the FFmpeg Library. Specifically, libavformat.so in order to convert audio files. I have FFmpeg fully installed. Any thoughts?

Same thing here (Ubuntu 20.04, audacity-linux-3.5.1-x64.AppImage).

There is some strange behavior when selecting the location of the library in Edit → Preferences → Libraries → FFmpeg Library → Locate → Browse. The file libavformat.so isn’t shown in the list of files, although the file is clearly there (in /usr/lib/x86_64-linux-gnu). Only libavformat.so.60 can be selected, but this has not effect, i.e., it is not remembered.

Then I tried to set the path by hand in ~/.audacity-data/audacity.cfg with:
[FFmpeg]
Enabled=1
FFmpegLibPath=/usr/lib/x86_64-linux-gnu/libavformat.so.60.16.100
However, it still fails to load at startup.

How can this be solved?
Many thanks!

Sorry to hear that you’re having the same issue. I found that deleting the AppImage file and installing Audacity from the command line (v 3.4.2) solved the problem. Or rather, Audacity is able to find the correct file when using the version installed from the command line. Hope that helps!

Thanks, that solved the problem!
(BTW: I am using Ubuntu 24.04 and not 20.04 as written above by mistake.)

Anyway, it’s a pity that the latest version of Audacity does not work with an LTS version of Ubuntu.

You’re welcome! I find it a bummer as well but let’s hope that future iterations solve the issue.