latency problems wont go away

Here’s my specs:

Dell Latitude E7250, windows 10
Blue snowball iCE
Bluedio T2+ headphones.

I’ve tried to watch countless videos with click tests and whatnot in them and have done them accordingly to fix my latency.
When I go to test my mic, it syncs up with what ever track im overdubbing with, i go to record a second part, and my latency’s all off again and the music isnt syncing up with my vocals. I am quite the amateur so I’d appreciate if anyone could guide me through this process in more detail. Thanks!

I think the first thing I would do is stop using bluetooth headphones. Bluetooth is a separate digital encoding and transmission process and all those steps take time. So the sound Audacity is sending to you and the music you’re hearing are different. Super convenient, but different.

I was about to suggest one of the common latency setups, but I know it’s likely not going to work with Bluetooth.

Let’s go anyway. Set up for overdub and Generate a click track. Play that back and jam your headphones against the microphone. I know you’d never use earbuds, but work with me here.

That will give you a new track under the click track.

Now do it again. You should get a third track that more or less matches the second. If all three are miles apart, then you have a very unstable system and overdubbing is never going to work until you fix it.

This is what I would expect before latency correction. Note 2 and 3 match each other but not 1. (This is an illustration. The waves are not perfect.)

Screen Shot 2019-09-18 at 17.00.03.png


There is a pretty common way to mess this up. How many things do you have running right now? Are you sure? Shift-Shutdown and wait for it to get done. This is a more thorough method of clearing out all the apps than just Shutdown or Restart.

Start and don’t let anything else start. Still have latency wandering? If you leave Skype running in the background, for one example, there is no way to get stable sound channels. Skype changes things and will always win.


Left out a step. SOLO the click track on the second pass so Audacity doesn’t try to send you two tracks. How did it come out? I’m on the edge of my seat.


Thanks! I will try the suggestions right now.

hmm i just did the first step but on the second track only 7 clicks are displayed.

hmm i just did the first step but on the second track only 7 clicks are displayed.

And the third track? If two and three match, you have an adjustment problem. If none of them match, you have a machine instability problem.

Again, make sure the first track has SOLO selected so you don’t get a multi-track pileup.

We wrote a thing on overdubbing. Are you following along?


only 7 clicks are displayed.

You can get odd recording problems if you have Edit > Preferences > Recording > [_] Sound Activated Recording selected. It should not be selected.