Latency keeps Changing

Audacity Screen.JPG
I’m trying to sort out my latency. I’m doing the click track record thing.

Windows 10 Machine fully up to date / Audacity 2.1.2 (I know there’s a newer version) / Line 6 UX2 patched

Latency is set to -80ms but as you can see it’s not adjusting it consistently

Any ideas?


There are some important assumptions in setting latency.

– You’re not filling up your machine.
– You’re not overloading your memory or other system.
– There’s nothing else on your machine that’s causing changes.
– That you’re using your internal drive with no other drives connected.

Common home machines live on violating 3 and 4. Running Skype, Zoom, or Meetings can be a major problem and using a cloud, external, or network drive can pretty much kill latency stability for overdubbing.

Disconnect your network or WiFi. Eject or unmount network or external drives. Clean Shutdown Windows: Shift+Shutdown > OK > Wait. Start. Do Not let applications start automatically.

When the machine comes back, start Audacity and do the latency test.


A Solid State Drive is recommended. Older spinning metal drives can be made to work, but they change characteristics depending on how full they are and the amount of fragmentation. Windows has tools to check your drive and “clean” it.

Screen Shot 2022-03-25 at 8.19.36 AM.png

This is not a “push one button” problem.


Try using MME or WASAPI as the “host” in the Device Toolbar rather than Direct Sound.
(make a note of your current settings so that you can set it back to how it is now if it’s worse).

And do post back if you get something to work.


It’s a solid state drive.

It’s a solid state drive.

And the rest of that? Any of those suggestions help?

You should note if any of those suggestions changes the problem, not just improves it.