latency issues

I have tried to record singing over a mp3 track which I have done many times in the past. However, now with the new upgrades to audacity, there has been terrible latency issues between the mp3 recording and me trying to record singing on a separate track. Years ago, when I first started using audacity this was not an issue. Can someone help me resolve this? Thanks.

[u]Latency Test and Compensation Adjustment[/u]

It makes me nervous when somebody posts like that. There’s two latency effects, machine latency and recording latency. Recording latency is the one you set in Audacity > Edit > Preferences > Devices > Latency. That setting makes it so when you perform to a backing rack, the new performance and the backing track overlay perfectly. That’s the one you set by holding your earphone up to the microphone as in the instructions.

The other one, machine latency, is the reason you can’t listen to the computer to hear yourself when you overdub. Your voice’s trip into the computer, to Audacity and then back out again is always going to take time and produce an echo. That’s why you always have to use a microphone or interface that has provision for “Direct Monitoring” and a headphone socket.


Windows 7 Audacity 2.4.1 External soundcard Creative Soundblaster SB0240
I’m trying to use Audacity for multiple overdubbing. I can’t sing but I do play guitar. I’m also shielding against Covid till I’ve had my second dose of the vaccine. I’ve recorded to mp3 from their YouTube the depleted worship band I normally play in (the lead singer has a superb voice) and I’m trying to add both rhythm and lead guitar. This seems to work fine for the first overdub, but even though I then mute my first overdub, when I attempt to record the lead guitar (direct from the amp), in my headphones I’m hearing the mp3 track, but also my guitar delayed by the machine latency. I don’t want to hear that - I can hear the original sound from the amp. I’m not using mics - the guitar goes into the amp, and the amp output goes into an 8 track mixer then into the soundcard. The machine happens to still be Win7 for historical reasons, though my main machines are Win10.

What I want to know is how to stop Audacity playing back to me what I’m now recording.

Ensure that “Software Playthrough” is OFF (not selected) in “Transport menu > Transport Options”.

Many thanks, Steve. Yes I can see it now in the FAQ!