Latency delay monitoring Toneport UX1

Hi guys I was hoping someone may be able to help me with a problem im having.

Il try and explain as best i can.

Im currently using a toneport ux1 external soundcard. It is connected up to my pc (running vista 32bit) via usb and to the monitor’s 3.5mm jack cable point with the analogue outs coming from the ux1 using a twin stero cable connecter.

The sound quality itself is great. BUT when listening whilst recording, i cant get rid of the half second delay. I have tried pretty much everything iv found across youtube/forums to correct latency issues but no joy.

Even when my headphones plugged directly into the ux1 the delay is still there. Whats even more strange is when adjusting the latency correction, its not affecting the delay at all. In other words it doesn’t shorten the delay gap.

I have spent a lot of time searching the forums but have not found an answer.

Any suggestions would be a great help because im really stuck.

Thanks in advance

Can I assume you’re trying to do overdubbing? There are two delays or latencies. Recording latency is handled with an Audacity setting. This is the setting that affects the accuracy of the overlaid sound. But there’s a second delay. Computer latency is fixed. That’s the one that lets you hear yourself live, usually late if you’re plugged into the computer.

If you followed the overdubbing tutorial, you know that you need to set the Overdubbing option to on but the Playthrough option to off.

Audacity > Edit > Preferences > Recording.

That gets rid of the computer delay, but the setup now has to provide your live voice through the soundcard. Not all of them will do that. In the illustrations, I picked three different hardware solutions that allow you to monitor with no latency.

For example:

Of course if you’re not overdubbing, then you need to tell us what you’re doing.


thanks for the quick response.

I have my guitar hooked up to my ux1, step one of what im trying to do is live recording. So i havnt selected to have the overdub option on in preferences.

When clicking record, everything i do on the guitar is delayed once played out of my headphones which are connected directly into the soundcard.

Obviously once i have laid down a recording i will be wanting to use the overdubbing but for now i was just hoping i could get rid of the delay.

I might have missed something completely obvious here but i cant seen to get it sorted. So would that be down to my ux1 not being up to the job?


Connected to which sound card?
Your headphones need to be plugged into the UX1 and “Software Playthrough” turned off (not selected) in the Audacity Transport menu.

Sorry, yes I meant to the ux1. But once turning off software playthrough im unable to hear what im playing live. Until I stop and playback what iv done.

Am I being a bit stupid or is this just a feature that’s not able to be done in audacity ?

Ensure that in the Transport menu “Overdub” is on (selected).

Im getting sound with no problems, its the latency issue. When using the audacity settings to adjust the latency it has no effect at all on the half second delay in sound that im getting through live play.

“half second delay” is not “no problems”.
I’m trying to help you.
Have you tried the settings that I suggested?

ok I appreciate the help I think im just getting a bit confused. I have tried the settings which you recommended, which were overdub switched on (in the transport menu) and software playthrough off. But without having software playthrough switched on I am unable to hear what im playing as I play it. Which is where I was having the latency issue.

Those are the correct settings.
Software playthrough will cause a delay, because the sound is being forwarded by the software, which takes time.
To get “instant” sound, the sound must be routed by hardware, and that’s down to the UX-1.

According to the UX-1 manual:

Phones - To listen using stereo headphones, plug them into this 1/4-inch stereo jack. This headphone
jack outputs the same signal fed to the Analog Outs: The audio from your audio software on the
computer, as well as anything plugged into any UX1 input.

So it looks like the UX-1 should be able to let you hear what your are playing. Check your settings on the UX-1.

Thanks for doing some research into the ux1, my headphones are connected directly into the ux1’s headphone port. I have tried changing around the settings and adjusting latency/buffering to try rectify the latency issue.

What is confusing me is whatever I do (settings adjustment wise) it simply has no effect on the latency. Which is why im completely out of ideas.

Is it possible that there is something on the pc I can disable or change? I do have the ux1 selected in the sound options as my default device.

I am almost certain the ux1 is not faulty, since trying it out on a friends pc using Cubase earlier on in the year and it working fine. Im just running through anything I can think of.

Appreciate the help

Ok, i have sort of fixed my problem. Whether this is the standard procedure with all external sound cards or not i dont know. But after downloading ‘Podfarm’ and having it open whilst playing, i am able to hear everything “instantly” with no latency. So as i would have to pay for podfarm what other options do i have to replace it?


I’ve done a bit more research for you and found this article ( which seems to suggest that the Toneport UX1 does not have real “zero latency monitoring”, just “Near Zero-latency Monitoring” (not real hardware monitoring) - that’s a problem when using Audacity :frowning:

They say that the Toneport UX1 is designed to be used with their amp modelling effects provided by the “Gearbox” software. I imagine that will work with reasonably low latency if you use ASIO drivers, but unfortunately Audacity cannot be distributed with ASIO support due to licensing restrictions. Both Audacity and the Toneport support WDM drivers (standard Windows drivers), but as you have discovered, software based monitoring using WDM drivers produces horrible latency.

For a low/no cost solution, I’d suggest that you try the Toneport with ASIO enabled software (such as Reaper or Kristal Audio Engine).

il try some bits out,
thanks again for the help and suggestions! Its very much apreciated.