Latency Correction Setting

I’m trying to record vocals over a track and I keep getting this message “Latency Correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero. You may have to use the Time Shift Tool (<—> or F5) to drag the track to the right place.” I saw an old forum involving this topic but it wasn’t helpful at all. The laptop I’m using is running Mint 14 if that is any help. I would appreciate some assistance solving this problem.

If you see the blue Pause button engaged when you try to record this is because you turned on Transport > Sound Activated Recording. Use the Transport Menu to turn Sound Activated Recording off.

Otherwise, turn off Transport > Software Playthrough. This often causes recordings to stall on Linux.

Also see the relevant FAQ’s: .

If you need more help, please tell us what equipment you are recording with (make and model numbers, and how you are connecting that equipment to the computer).


Hi, sorry for taking so long to respond. I am using a CAD u37 USB mic on a Toshiba Satellite laptop. I checked the settings you mentioned and Software Playthrough along with Sound Activated Recording are both off. However I am still experiencing trouble dubbing recordings. I can record fine, but trying to record over something else I get the Latency message. I am running Linux Mint 14.

Then the recording is still stalling as soon as it starts, so when you press Stop, the fragment of track is pushed behind zero.

Try changing the input device in Audacity Device Toolbar ( ) to an (hw) choice which gives you direct access to the hardware.

Change the USB cable and put it in a spare USB port (not a USB hub).

At Edit > Preferences: Recording in Audacity, try increasing audio to buffer and see if recording will then start.


I was just having this problem with a USB mixer (Lexicon Lambda) and a default sound card on my laptop.

I played with settings for an hour, then set the Output device to ‘sysdefault’ and totally resolved the problem.

FYI. :slight_smile: