Latency Correction error

Audacity 2.1.2 / Windows 10

I’m using a USB soundcard to record and It was working previously.

I’m now getting the latency correction error.

I’ve tried updating the driver on the soundcard and re-installing too.

Any ideas please?


There’s two latencies.

Recording Latency is the one you set in Audacity preferences so when you overdub, the new performance overlays the old one perfectly. Machine Latency is the reason you can’t hear yourself without echoes in your headphones when you perform overdubbing because of delays inside the computer. That one’s not adjustable and it’s very difficult to get rid of.

Did I hit it? Are you overdubbing? Describe your microphone, system and job.


What is the exact error message?

I assume you are overdubbing, that recording has stalled, and you are seeing a message about latency correction pushing audio behind zero.

Do a cold boot. Click the Windows button, then the Power button, then hold SHIFT on your keyboard while clicking “Shut down”. USB recording devices need this. They do not record for ever without cold booting.

Also make sure the USB device is connected to an empty USB port on the computer. Do not connect a USB computer hub to a USB port then connect the device to the hub.

Do tell us exactly what this USB device is if it still stalls after reboot.


I’m not overdubbing no.

Just trying to record from scratch.

I tried the reboot with the shift key but didn’t make a difference.

I’ve attached a screenshot of the exact error message.

Thank all.

Yes you are. If Transport > Overdub is not ticked (not checked) and if you have no other tracks present, then the message you show does not appear - instead the recording will just stall. The stall is what you have to fix.

Please give the make and model number of this device and tell us exactly what you are trying to record, for example a boom box connected to Line-In of the sound card.

Have you replaced the USB cable and tried another USB port?

Also look in Edit > Preferences…, Recording section and try increasing “Audio to buffer”.


Sorry, you are correct re overdubbing.

I’ve un-ticked that.

Also tried to increase Audio to buffer but no difference.

The external USB card is connected to a mixer and it’s the audio from the mixer I’m trying to record.

I don’'t know the make or model as there are no details on the box itself.

I’ve tried using another USB cable on another USB port.


So it is a USB mixer - and if not, how is it connected to the computer, exactly - to what port?

Mixers do not usually have USB inputs. Or do you mean that the analogue outputs of the USB sound card are being fed into the mixer? What exactly are you trying to do?

If the mixer is unbranded for example from China it may not work. Has it ever recorded into Audacity?

Exactly what recording device have you chosen in Audacity’s Device Toolbar and how many recording channels? What project rate are you using (bottom left of Audacity)?

Please also attach the information from Help > Audio Device Info… top right of Audacity.


It’s not a USB mixer no. Regular DJ mixer.

The output of the mixer (rec out) is being fed into the USB soundcards line in.

It has recorded perfectly before yes.

Device info text file attached.
deviceinfo.txt (9.26 KB)

NME / Line 2 (USB) / 2 (Stereo recording channels)

Your Audio Device Info said that the Microphone Array was selected as Audacity Recording Device, so please double check.

You can try changing the host from MME to Windows DirectSound or Windows WASAPI, or try a different project rate (bottom left of Audacity).

If you installed some new audio software just before the problem started you could uninstall it, or try Windows System Restore to a previous restore point (if you have System Restore enabled).

As a test you could see if Windows Voice Recorder can record your USB card. Go into Windows Sound, Recording tab, and make Line (2- USB Sound Device) the default recording device. Click Windows Start, type “recorder” (without quotes) then press ENTER on your keyboard. Click or tap the microphone icon to start recording, and click or tap the Stop button when you’re done.

It should not make any difference, but making Line-in of your sound card the default Windows recording device “might” help the problem. In that case you can, using MME host, try recording from Sound Mapper - Input instead of Line (2- USB Sound Device). Sound Mapper - Input is whatever is the default Windows recording device. You would be choosing the same device, but If the USB device or system is buggy, it might make a difference.


System restore did the trick.

Thanks for all your help Gale!