Latency Compensation not working

3.1.3 for Windows
Windows 10 Version 21H2 (OS Build 19044.1706)

I have successfully done the latency test and compensation on another laptop.

Both times I’ve been carefully following these instructions:

I am recording the clip with a mic (Sennheiser e 609) which is plugged into my mixer (Yamaha MG10XU) with a USB out to the laptop.
Headphones (Sennheiser HD 280 Pro) are coming out of the laptop which is my sound source for the click.

I’ve zoomed way in on the track and carefully measured the distance from the generated click to the recorded click. Starting at the beginning of the generated click to the beginning of the recorded click = .698

I’ve entered -.698 into the Latency compensation box in Edit > Preferences > Devices
(Buffer length is set at 100 milliseconds)

When I did this before, the track would shift after recording and line up. It’s not doing that now. So the problem is I still have latency.

Thanks in advance,
Paul V

Hi. Typical Latency compensation values for Windows PCs should be in the 60 to 120 milliseconds range. 0.698 milliseconds is a very uncommon value.

You could try to estimate the required latency compensation using the automated test described in this forum post:
Please note that it is still in beta so we could all benefit from your feedback.

Thanks, I’ll have a look.

I haven’t had a chance to get back to this, but forgot to add that I’m playing my electric bass through an active preamp, then into the mixer. Maybe this is what is making the latency abnormally long…

No, the latency occurs while the computer is collecting audio samples in its buffers - it’s all inside the computer. The guitar, preamp, and mixer are all live and unbuffered. :smiley:

The “Latency compensation box in Edit > Preferences > Devices” is in milliseconds.
0.698 milliseconds is impossibly short.
0.698 seconds is rather long and seems unlikely, but if that is correct, then it should be entered as -698.

Try setting the “host” to “MME” in the Device Toolbar.