Latency Compensation has no impact at all.

Hello everyone,

I apologies if this has been posted before but I have looked all over the web and cannot find a solution.

I am running Audacity 2.4.1 on a mid 2012 macbook pro running macOS 10.15.4 catalina, I am trying to use audacity to record simple vocal audio over instrumental tracks. I am using a focusrite 4i4 audio interface with an audio technica AT2020 microphone, I have all the proper drivers downloaded and Audacity recognizes the audio interface as the input and output device. The microphone is working and when “software playthrough of input” is disabled I can hear myself perfectly in the headphones with no delay. However when “software playthrough of input” is enabled and I record a very noticeable delay occurs making vocal recording almost impossible as the vocals do not sink up properly with the track.

This suggested to me their most likely was a latency issue with the help of google I completed a latency test using my headphones with “software playthrough of input” disabled. I was able to determine that the latency correction needed was -103. So I inputed this into the settings but it had no impact I tried increasingly ridiculous figures just to see but the delay remained completely unchanged and from what I could tell stayed exactly the same at every input I tried,

I think it is very important to note after initially discovering the issue I tried recording using a friends laptop also running Audacity 2.4.1 and it worked perfectly on the first try with no need to adjust any latency settings.

Any and all advice would really be appreciated as I am truly stumped and cant record anything as it is all slightly delayed.

Thank you in advance.

The latency correction applied by Audacity corrects for the latency when recording the new track. It cannot do anything about the latency when using “Software Playthrough”.

If you have done the latency test according to this page in the manual then you have determined the correction that needs to be made for the newly-recorded track.

Please see this page for a complete description of how to do multi-track overdubs in Audacity.

– Bill

You can’t listen to the computer for overdubbing. You have to listen to the microphone, mixer, or interface.

You are adjusting recording latency. The sync between the new and old track when you get done. Computer headphone sound will always be “one computer late” because of machine latency. You’re stuck with that.

Koz

I know nobody in their right mind would do overdubbing using earbuds. They were handy for the pictures—and they do work.

Koz

MTLmusic71:

Your posting was made in June and I don’t see any follow-up from you.
Did the responses you got here answer your question, or solve your problem.
I may be mistaken, but it seems to me that the answers you got didn’t really address your problem, which was that the latency correction was having no effect at all.

I’m looking at this because I have the same problem. I followed the instructions for determining the latency and I applied this amount as the latency correction in Preferences>Devices.
But, when I record a test track with the latency correction set, the newly-recorded track has no latency correction applied to it. The little arrows that are supposed to appear, telling me that latency correction has been applied, do not appear.
I’m using Audacity 2.4.2 on a Mac running OS 10.13.6

I followed the instructions for determining the latency

By which method? There are several different ways to measure recording latency. Play a live instrument to a drum beat, the microphone method illustrated, shorting analog cables, etc.

There are some magic ways to have the adjustment fail. In the case of matching metronome beats, you can be one beat cycle off. It will seem like nothing moved, but really, it moved too far.

I use the rhythm pattern with two different tones. TICK took took took TICK took took took. It’s much harder to miss the match and no adjustment is likely to be five beats off.

The little arrows that are supposed to appear, telling me that latency correction has been applied, do not appear.

I need to look that one up. I don’t think there were arrows the last time I did this. Do you have overdub selected in Audacity > Preferences > Recording > [X] Overdub.

Koz

I just did a latency test on this machine. It’s clearly off, but I don’t see any arrows. Did I miss something?

Screen Shot 2020-10-22 at 10.50.56.png
Screen Shot 2020-10-22 at 10.51.50.png
Koz

Arrows don’t happen any more. They were more trouble than they were worth as they greatly complicated exporting multiple tracks. They also created problems and inconsistencies for append record and pre-roll.

What “should” happen is that the latency correction moves the track to the left (to compensate for the latency) without adding any padding to the start or hiding extra audio behind zero.

Arrows don’t happen any more.

OIC.

There is another possible failure. You can be ultra cautious and apply a correction that’s too small to see. Add or subtract 100 to what’s there and see what happens.

You understand you’re required by the State of California to go the wrong way the first time and make latency worse? Little known fact. What you’re supposed to do is note the difference between the old and new time line positions and add or subtract it to/from the negative latency value already there.

You sort that out. I’ll wait.

Koz

As Steve points out we failed to update the latency test page in the manual when the time-shifting left-arrows were removed. Latency compensation still works as described. But in the second-last illustration there will be no left-arrows and no audio to the left of time zero.
– Bill