Lame and FFmpeg libraries not where they should be[SOLVED]

Mavericks 10.9 on a 13" macbook pro retina
Audacity 2.0.5

I’ve opened an m4a file and trimmed both ends. I now wish to export it out as an m4a file. I’m told I need the library installed for this and for mpg. So I followed the instructions here:

During installation, I’m not told what the file will be called, nor where it will be installed. My only choice as to where to install it is “on my HD” Nice. When I look where the “we can’t find it” dialog expect to find it, that path does not exist on my HD. When I search for the filename, that file does not exist on my HD. I have restarted Audacity. I have rebooted my machine. I have tried the library installs a second time. Everything installs fine with no errors, but I can’t for the life of me figure out where the library goes, nor what it is called. Attempting to export to m4a just tells me that I "need a properly configured FFmpeg to proceed. Obviously the installer isn’t putting it where Audacity would like to find it. I seem to be the only one having this particular issue, so I’m sure it is something I biffed. Be gentle… this is my first Mac.

Who wants to be my new best friend?

  • Darell

Mac sometimes likes to lock out /usr/local so that you cannot “hurt” your system.

I suggest you forget the installers and follow the instructions for the zip files instead: .

If you extract each zip download to the folder where you installed Audacity then restart Audacity, it should see LAME and FFmpeg automatically. Otherwise, using Libraries Preferences to browse for the location where you extracted the files to should work.


Followed the instructions (twice to make sure). In the end, the file I’m supposed to “open” doesn’t exist in the extracted folder. In either case.

I tried. I tried twice. I extracted the Zip, and dragged the resulting two (minus the .txt file) to the location that the instructions suggested (a folder on my desktop named exactly what they say, AND to the folder where I installed the app as you suggest. No luck either way. And the two files I get from extracting - aren’t anything like the instructions tell me to go find. It’s like I’m in a different world from what I’m supposed to be seeing here. And what the app wants to find from the Prefs>Library isn’t anything like anybody suggests.

What do folks mean when they tell me that “sometimes” Macs like to lock certain things out? This isn’t a consistent thing? More of an art than a science? It isn’t something we can work around? What’s the big mystery here? Yikes!


Unfortunately we cannot see your computer so we cannot tell what is happening.

If you want to know why Mac sometimes locks /usr/local/ and sometimes not, you can ask an Apple representative. I am sure you won’t get a straight answer.

Your permissions could be broken (something else that can happen on Mac). To fix it, open Finder, choose Go > Utilities, open Disk Utility then “Verify Disk” and “Repair Permissions”.

If your permissions are not broken it would be possible to give you an audacity.cfg file that told Audacity where to find the libraries, but I think that will be hard for you if you are new to Mac.

I would suggest instead you export as WAV from Audacity and convert to AAC in iTunes.

  1. Drag the WAV file into iTunes.
  2. Click iTunes > Preferences.
  3. Click on the “General” tab.
  4. Click the Import Settings button half way down on the right.
  5. In the “Import Using” dropdown, choose “AAC Encoder”.
  6. Click OK and OK.
  7. Select the file to be converted, then right-click or control-click over it and choose “Create AAC version”.


Thank you kindly. I verified and repaired permissions. But what finally helped is getting hold of a zip file that had both libraries I was looking for… and was complete. I dumped them both into my Audacity folder (in the Apps folder) and everything works like a champ now.

Still no idea what the problem was - maybe I didn’t drag the whole Audacity folder over to the Apps folder originally??) No clue. But everything is working now, and I appreciate the help!

Good. The zip files linked to in the Manual are correct - I already rechecked them.

I’m locking this topic now if you don’t mind as it’s better for others to start a new topic if they have a LAME or FFmpeg installation problem.