Ladspa plug ins?

Hey everyone,

I hope somebody can help me because I really don’t know what to do anymore. So I downloaded the ladspa plug ins and everything went fine but as soon as I tried to enable them a notification showed up which said:

Effect at C:\ProgramFiles(x86)\Audacity\plug-ins\ladspa-util.dll failed to register

I need those plug ins to edit a song and it’s so frustrating because I feel like I already tried everthing except downloading the 32 bit version of those ladspa plug ins but the problem is that I don’t know where to find that version but I read that it worked for others.
If anyone knows how to download the 32 bit version or ever had the same issue before and knows a solution I would be very very grateful because I feel so desperated.

Is that the “set of over 90 LADSPA plug-ins” mentioned on the Audacity website:

Those plug-ins are all very old and you may be better to find a VST alternative.

Which version of Audacity? (look in “Help > About Audacity”)
Which specific effect(s) are you after?

Yes it’s the “set of over 90 LADSPA plug ins” and I use the 2.2.2 version. I especially need the gverb, hard limiter and delay effect

Have you tried the Reverb, Limiter and Delay effects that are included with Audacity?

The standard Limiter effect in particular is a much better limiter than the LADSPA version.

I don’t recall exactly what the LADSPA Delay effect was like, but my guess is that one of these two effects will work just as well:

GVerb was quite a distinctive (and frequently “over the top”) reverb effect, so that one may be difficult to replace if you want that exact sound. Audacity’s standard Reverb effect tends to give a more subtle and natural reverberation:
There’s alsob this free VST reverb effect that has some very nice sounds:

I don’t have any limiter or delay effect I only have the echo one. Where can I find those? And also the VST plugins you mentioned earlier

They are included by default in the current version of Audacity. Perhaps you have a very old version of Audacity.
The current version is Audacity 2.3.0 and it can be downloaded here:
Run the .EXE installer to upgrade your current version.

The VST reverb effect is available here:

Okay so I just downloaded the latest version 2.3.0 and went to add/remove plug ins and hard limiter, gverb and time scale were in the disabled section so I tried to enable them and thought it worked but then I couldn’t find them in my effects so I went back to add/remove plug ins and they were disabled again. What should I do now? Do you know where to find the 32bit version of those ladspa plug ins because I’d like to have as many as possible of them so I can try out new things

The LADSPA plug-in from the Audacity website are 32-bit. As far as I’m aware, 64-bit versions do not exist.

Look in “Edit menu > Preferences > Effects” and ensure that “LADSPA” is enabled.

Alright so first of all thank you it worked and now I have many of those effects I don’t understand why it didn’t work with Effect > Add/Remove Plug Ins > Ladspa > Enable but nevermind. Unfortunately there is still no limiter or delay :frowning:

Look in “Edit menu > Preferences > Effects” and ensure that “Nyquist” is enabled (all of the effect types are enabled by default).

Thank you so so much I really appreciate your help!

All working now?

Yes thanks for your patience :slight_smile: