Keyboard shortcuts not working [SOLVED]

I have no idea why this would suddenly be an issue–been using Audacity for many years. But have been working on some songs recently and my keyboard shortcuts aren’t working. No space bar to play or stop, so cmd-C or cmd-v to cut and paste. Nothing. I checked my settings and everything appears to be set up properly. What could I be missing?

Wanted to add that NO keyboard inputs are working. I can’t name my labels either. Can’t find any reason why this would suddenly be happening.

Which version of Audacity? (look in “Audacity > About Audacity”)
Do you custom shortcuts or the default ones? Have you tried resetting the keyboard defaults in Preferences?

I was on 2.1.1 and it was a problem, so I downloaded and installed 2.1.2 to see if it would fix it and didn’t. I have never made custom keyboard shortcuts, always used what was available. So I also went in to create a couple custom ones to see if it would fix it, but it didn’t. But as I said in my first reply here, it seems NO keyboard inputs are being recognized since I can’t even type in labels. I can click on the blank box but it will not accept any input from the keyboard. Having no issues with this in any other programs.

I’ve not heard of anyone else having this problem.
Have you recently updated to Sierra?
Any other issues with Audacity? for example, are all of the effects and generators present in the menus? (Look for “Pluck” and “Risset Drum” in the “Generate” menu).

Try resetting Preferences completely by

  1. Close Audacity
  2. delete the audacity.cfg file (
  3. Restart Audacity.

To be 100% precise, Steve meant Quit Audacity there.

Exactly what keyboard are you using and how does it connect to the computer?

Does clicking on keys in the On-Screen Keyboard work in Audacity?


My hero! It worked. Thank you! Hopefully this will speed me up on my overdue project!