keyboard amplifier sounds a rattling automatic gun

Hello : i connected my keyboard (yamaha psr s650) to my keyboard amplifier (behringer 15watt); In audacity when i try to record from my keyboard playing it gives a weird rattling gun sound!? I can’t fixe it with the help files. Can someone please help me. Thanks.
Attachement in wma .
ampli.wma (128 KB)

How exactly are you doing that? (For example, using a Rode NT1-A microphone placed 15 cm in front of the amplifier speaker, with the mic connected to the computer via a Focusrite 2x2 USB microphone pre-amp with phantom power enabled on the Focusrite, and Audacity set to record from the USB audio device.)

Does Audacity record the notes that you are playing as well as that noise? If so, please post another short sample, preferably in 16-bit WAV format, including some notes played on the piano.

That’s feedback. One of your sound pathways has found a complete loop. It’s a lower pitch version of the club band getting the microphone up too loud.

In audacity when i try to record from my keyboard

I’m with Steve. How?


To steve:
Audacity record the notes I play on the keyboard as well as the noise.

Is that faint organ sound behind the noise the sound that the keyboard is playing?

How are you recording the keyboard?

yes it is the sound that the keyboard is playing
I connected the keyboards phone/output with the line-in at the pc and connected the pc to my keyboard amplifier

Are you sure that your PC has a “line in” and not just a “mic in”?


Yes, my PC has a Line-in
connected my pc to the amplifier via the green line-out on the PC

Do you have “Software Playthrough” enabled in the Audacity “Transport menu > Transport Options”?
If so, turn that off (so it is not selected).

Do you have “Listen to this device” enabled for your sound card in the Windows Sound Control Panel?
If so, turn that off.

In Audacity “Help menu > Diagnostics” select “Audio Device Info”.
Save the info somewhere convenient, then attach the saved file to your reply.

Thank you so much ! resolved : I turned off “Software Playthrough”
Stupid me ! Glad you helped me trough this.