Keep getting an error with "crossfade clips"

I closely read this topic and I have the exact same problem, but since the topic is very old and I am on Windows (Audacity v3.4.2) , I thought I’d rather open a new topic.
No matter what I do, I can’t get “Crossfade clips” to work:

  1. open a new project
  2. import a sample audio (here applause from a live recording, stereo, sample rate 44,1kHz)
  3. create a DTMF signal and append without a visible gap to 2) for crossfading
  4. select a range across the clip boundaries (a few seconds on each side)
  5. Apply “Effect → Steve Daulton → Crossfade clips”
  6. get an error: “…More than 2 clips selected”
    Zooming in into the boundary just shows the expected gap of one sample interval - no extra clip.

Experiments on the following variants (select range, apply effect) all resulted in the same error:

  • Joining the two clips and splitting them again
  • trying on splits inside clip 2 (applause) or clip 3 (DTMF)
  • trying even on joined clips (well, this IS definitely les than 2 clips selected …)

What am I doing wrong?

It’s a bug: Crossfade Clips fails when Audacity is set to Deutsch (German) · Issue #5848 · audacity/audacity · GitHub

I posted the fix here but unless you are familiar with editing Audacity’s translations your best option will be to work around the issue.

Workarounds:

  1. Change the Audacity language settings. (English should work)
  2. Downgrade Audacity to an older version.

If you make two separate tracks you can make a “manual” crossfade.

oops - UI language setting was about the last culprit I would have thought of, Thanks a lot for sharing, @steve!

Thanks for the reference to Crossfade tracks @DVDdoug . I tried this already but it would have been quite some effort to pull out the to-be-faded clips into a separate track, so I thought I’d stick with Crossfade Clips.