Just updated Audacity to latest version now no audio devices found

My audacity was just working fine on my Windows 10 computer. I just realized that I have a super old version and updated to the latest version. Now no audio devices are showing up. I checked windows and my blue yeti mic is set as the default mic. I restarted my computer. I tried transport = rescan audio devices. I shut down my computer. I plugged the mic into another USB port and opened Audacity again… NOTHING WORKS.
What must I do, Please help.


Try clicking “Reset Configuration” in the “Tools” menu, then restart Audacity.
Can you see a USB option for the recording device in the Device Toolbar?

Thank you so much, Steve for replying. Sorry for only coming back now, I don’t come near my computer on Sundays and it was a bit late Saturday night here by me to see your answer.
I tried that, it’s still not working.
I also removed Audacity completely and reinstalled it… Still did not work.
I found another answer where Windows might block it, it’s set to allow.
I looked in my Kaspersky if it’s blocking it, it’s on allow.
So I don’t know what to do, I’ve tried everything :cry:
The devices are completely empty.
thank you

Are you referring to “permission to access microphone”?

Hi Steve,
I’m not sure if you received my last reply.
On your question: Are you referring to “permission to access microphone”? Yes, that one.
I’ve tried everything I can think off. All the other things in the forum where advice was given, I tried.

Please help, I need Audacity.


What audio devices does your computer have (including USB, firewire, etc)

I took a screenshot from Windows, it’s easier than for me to try to remember all of them because there are a few funny ones. (see attached)
The funny thing is, is that Audacity worked just fine before I updated to the latest version. But the version I had was super old. I can’t remember right now which one it was, but it was something like 2.04 or something.
Screenshot (297).png
Screenshot (296).png

What I did now was I copied an old version of Audacity from my laptop (version 2.1.3) to my computer. Now it’s working fine. Maybe I should not use the newer versions?

Do you need Voicemeeter?

I don’t know. My audios are usually very soft, why I don’t know because I use a Blue Yeti and it’s supposed to be a great mic. Do you think it’s voice meeter that’s causing the problem?

It could be. I’m not very familiar with VoiceMeeter (I rarely use Windows), but it’s a complex piece of software that integrates tightly into the sound system - if it isn’t configured or working correctly, then it could certainly interfere with Audacity.

Since I copied and uploaded the older version of Audacity to my computer it’s working fine. I think I’ll stay on the older version for now to be safe.

Thank you for your help and your time. I still don’t know what is wrong because on the older version I’ve got voice meeter and it’s still working, so I truly don’t know. This is version 2.1.3. I attached an image of all the devices in Audacity, which is empty when I try to use the newest version.

Screenshot (300).png