Jerky Recording/Playback Cursor

I’m a long time Audacity user using a 2012 MacBook Pro I7 Intel 2.3 Ghz processor with 16 GB Ram running MacOS Mojave 10.14.6.

Starting with audacity 3.1.0 and so far through 3.1.2 and an 3.2.0 beta build I just built, the recording/playback cursor is very noticeably jerky. Please note the jerk is the same on recording or playback. Version 3.0.5 does not exhibit this condition, though there is a very very slight jerk that isn’t noticeable unless you are looking for it. At the normal edit/recording zoom of CMD-2 it seems to jerk every ½ second or so. I see it even at zero zoom, Cmd-F, but not so evident. It seem like a buffer swapping/filling issue just off hand.

Is there any way to deal with this as it is now?

While I don’t know how to fix this, I can tell you that a smoother playback cursor is on the to-do list for 3.2:

Thanks for the reply. I’m glad it’s being worked on and I’ll be looking forward to it being fixed in 3.2.0.

Coming back to this issue after downloading Audacity 3.2.2. Cursor still VERY jerky. It’s very distracting. Any way to deal with this other than use an old version of Audacity, i.e. 3.0.5 or older?

As a reminder this is on a MacBook Pro, I7, 16GB and no visible load on the CPU. MacOS Mojave.


Also see these threads:

I have tried that and no help.

Am I the only one to see this?

Version 3.0.5 works just fine and all versions after that have the cursor that seems to get out of sync and jumps ahead to get back in sync. Jerk is about every ½ second.