Izotope VEA and Audacity

Was excited to see the new Izotope plugin for dialogue, VEA, even though compatibility with Audacity isn’t listed. They have both VST and AudioUnit versions, which have worked in the past for Izotope plugins on Audacity, so I was hoping it would work, even if it’s not officially supported.

It doesn’t. :frowning: Everything locks up when previewing the audio.

Is there a reason some VST plugins work and others don’t? Has anybody been able to get VEA to work in Audacity?



I don’t know but compatibility is up to the plug-in developer, not the host/DAW developer. (That’s why the “legit” commercial plug-in developers give you a list of officially supported hosts.)

I sometimes get the impression that it’s related to the anti-piracy (iLoc?) built-into the plug-ins not being compatible with Audacity, but that’s just a guess.

1 Like

Thanks for the info, Doug! Will check with Izotope and report back here if I can find any more info.

So, Not seeing that there was a trial version, I purchased VEA and while it dont lock up as the OP issue, I dont know how to use it with Audacity. One can not play the audio clip once VEA is loaded, so “Preview” it is, only problem is the interface never gets beyond “listening” to the GUI with the dials. When you stop the preview, you got nothin. I donno…YES I guess that is the Definition of Locking Up! Sorry OP…you waz right

@mitch, try using it from the “effects” button at the left of a track. This will let it listen without locking up. However, I was unable to get it to do anything to the audio at that point.

Hopefully the full process will work for you. Please reply back and let us know.

Doesn’t work on my PC. Tried both ways mentioned here and see the identical issues mentioned above.

David and everyone hi,
Yes it did work for me when using non-destructive effects.

But in that I’m so used to editing in good old destructive mode, my problem now is that in non-destructive editing one cannot see the changes in the spectrograph nor wave, and I need the visuals to help me fine tune the changes and by extension the sound is changed but all of the analyzing elements and the ACX check, for example, remains unchanged from the prior sound.

So it works it does change the sound, but I can’t quantify it in any way shape or form.

That’s where I am now.

@mitch - thanks for the update. Took the plunge, purchased it, and am having the same experience.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.