issue with mouse bindings and Apple Screen Sharing

I regularly operate a Mac Mini (10.9.2) from my 13" MacBook (10.6.8) and edit audio using Audacity. I just got a new(er) 13" MacBook Pro (10.11.3) and am trying to do the same tasks.

The issue is that while Screen Sharing from my MBP (10.11.3) my keystroke-mouse wheel controls (ie: “⌘-wheel up” to zoom in) in Audacity don’t work, while on my 13" (10.6.8) they work perfectly (as if I’m sitting at the Mini itself). Other controls (like ⌘-I to split, etc) still work, it’s only the mouse-wheel ones that are misbehaving.

All machines are running Audacity 2.1.2

The situation has devolved to me screen sharing from my new MBP to my 13" to the Mini. It actually works normally that way. Opening the Audacity file remotely causes unbelievable lag in all controls, so I avoid doing that when I can.

I’ve tried changing System Settings, disabling the mouse-zoom system settings like the wiki says to do, and have checked Audacity’s preferences across all three machines. I continue to be frustrated.

My goal is to be able to control Audacity normally from my new machine.

keystroke-mouse wheel controls

You didn’t say anything about a mouse in your equipment list. MB and MBPs don’t come with one. If you’re using your touch-pad simulation, those changed enormously over the versions.


I just noticed that the pink warning at the top of the screen asks me to identify the type of installer used.

My new MBP (the troublemaker) had the .zip, the other two had the .dmg. Could it be as simple as that?

I doubt it. You get the same installer. I think one comes with the instructions—something like that.

Still waitin’ on that mouse info.


I have a USB “iHome” (non-Apple) wireless mouse plugged into my 10.11.3 machine; it used to be on the 10.6.8. I have turned off the “Scroll Direction: Natural” setting in System Preferences on the 10.9.2 and the 10.11.3 machines (the 10.6.8 one didn’t have that feature). But the behavior I’m asking about persists even when I use the trackpad, and when I used the same mouse on my old machine it behaved normally.

USB “iHome” (non-Apple) wireless mouse

But you get a similar effect from the trackpad.

You have a celebrity problem. The idea of the forum is a meeting of people with similar equipment to compare problems and solutions. Celebrity installs have no similar people.

Anything in the Apple forums about mouse management problems or changes in Yosemite? I’m not looking forward to my first Yosemite machine (coming soon to mailbox near me). Aggressive new battery-saving features have already created noise problems on newer machines.


Everything is fine if you run Audacity locally?



I’m not clear on what you mean by “celebrity”. I have three Macs all running Audacity and a problem with Audacity. I thought that the Mac OS X sub-forum on the Audacity forum was the place to talk about my issues.

yes it is, but, unless someone else on the forum has:

  • A Mac Mini
  • A MacBook Pro with El Capitan 10.11.3
  • A keystroke-mouse with wheel controls (specifically: “⌘-wheel up” to zoom in)

they know precisely how to set it all up for Mouse Keyboard and Screen sharing? Over wifi? Via a wifi router?
Without having the full list at our disposal to duplicate your set-up, there’s not much we can do.

Fwiw, I’ve set up mouse / keyboard / screen sharing to a Mac Mini that is running El Capitan, form my laptop which is running Debian Linux, over wifi via a wireless router, but my mouse is a standard 3 button wheel mouse and there is a noticeable lag between things showing on the display attached to the Mac Mini and displaying on my laptop. The delay in my case is primarily due to the speed of the wifi transfer but is not helped by the fact that my laptop is a bargain basement model that’s nearly 10 years old.

If we were talking about a problem with Audacity itself, then we could probably help, but troubleshooting networking problems that occur with specific hardware / operating system combination would be tough even for someone that happens to own the same gear. Have you tried asking Apple support?

I don’t think this has anything to do with Audacity or your particular mouse, but everything with El Capitan.

The easiest test is to try any other app on the Mini over screen sharing that uses the same shortcut. I seem to remember that many graphic programs do. If you can’t find one, try CTRL-mouse wheel, that will zoom the entire screen, even in the Finder if it’s enabled.

I do have a machine with EC to test, but I don’t see which setting could be changed between Snow and EC. And I can only get to it tomorrow.

There are more keyboard shortcuts that have been changed, especially in screen sharing, tho… I suppose Apple has been adjusting to iOS again.

Have a look at this Stack Exchange question, fi:

There’s nothing special with this mouse, Steve. It’s just a common mouse and pushing the command key while using the mouse wheel is a common way to handle zoom. Anyone can test it, even with a trackpad, as it is the equivalent of command + two finger swipe up and down on the trackpad.

But I think screen sharing on EC is the issue here…

Celebrity Problem. It’s such a specialized failure we’re not completely sure where to start looking—or how.

Correct me, Audacity appears to be doing what it was designed to do: work on one machine as a local task.


Screen sharing is quite common on Macs and works with nearly any app. I can’t even think of an app that doesn’t work with it.

I use it for recording, fi.

I didn’t say sharing was a celebrity, I said the problem was. Somebody would have to recreate the environment and have it fail the same way.