Is PlayLooped changed/broken?

I’m testing our Blender pipe to Audacity add-on on Audacity 3.2 and for some reason doesn’t the PlayLooped command start playing in Audacity. Has the usage of this somehow been changed or broken?

Send: >>> SelectTime:End="9.691666666666666" RelativeTo="ProjectStart" Start="0.0"
Rcvd: <<<
BatchCommand finished: OK

Send: >>> PlayLooped:
Rcvd: <<<
BatchCommand finished: OK

Send: >>> Stop:
Rcvd: <<<
BatchCommand finished: OK

I can see that loop playing has been separated into two functions, with a separate button for Loop On/Off, however the documentation is still referring to PlayLooped: Which makes sense since 3.2 is not out yet, but will there be a way to call the loop playing through scripting in 3.2?

In a Macro, Loop Play can be toggled on / off with the command:


However, it does not fully work for me with Python. The loop region is created, but the loop button is not depressed. Then, on sending the “Play:” command, the selection plays once and stops. Curiously, at this point the Loop button is depressed.

I’ve logged these issues on the GitHub issue tracker. Thanks for reporting the issue.

Commands relating to looping in Audacity 3.2.0:

  • Set Loop In = SetPlayRegionIn:
  • Set Loop Out = SetPlayRegionOut:
  • Set Loop to Selection = SetPlayRegionToSelection
  • Loop On/Off = TogglePlayRegion

I’ve not found any way to play looped (tested on Linux), which I think is a bug. I’d expect that “TogglePlayRegion” should enable looping, then “Play” would play looped, but that does not work currently.

Thank you for the quick reply.

I’ll stand by till a solution has been implemented.

I think this will be the issue to watch:

No sure what the conclusion here is? Is it considered just a documentation problem, and play looped will not more be able to be initiated by scripting?

Users are complaining over the Blender add-on for round-tripping audio in Audacity is broken due to the missing “PlayLooped:” command in Audacity. So, what is the status on this? Or are there any workarounds I can use instead?

According to the issue tracker ( there has been no change, though I’ve not tested to see if the bug is still present.

If it’s still the same in the current Audacity 3.2.4, it may be worth taking the issue to the Audacity discord channel ( as some of the development team are sometimes there.

Looks like the Play: is also broken. It is as if it enters a playmode, however the playhead is not visible on the timeline. If you click in the timeline ruler, it plays from that point immediately.

In other words, Play: doesn’t work like the play button, as I would expect it to do.

I also tried PlayAtSpeedLooped: and the problem here seems to be the same?

But it seems like SetPlaySpeed: is also initiating a pop up window.

So, it still isn’t possible to do anything which can replicate the old PlayLooped: function, which basically means that our Blender add-on for roundtripping all Blender audio strips in Audacity is still broken.

This is getting quite frustrating… as I’ve spend several weeks on doing that add-on, which connects two of the best and oldest open source projects.