iRig Recording Delay

I want to hear the actual guitar sound that is being recorded whilst I play. However, when I record my guitar there is a noticeable delay between what I play and what I hear through the headphones.
I’m using Audacity 2.1.0 on a Dell Inspiron running Windows 10. My guitar is plugged into an iRig HD2 and I’m using the headphones connected to the iRig. The mic is set to the iRig as are the speakers. Host = MME. I’ve downloaded ASIO4ALL 2.14 as some posts on here suggest that it is solution but it had no effect. I changed the value in “Latency Correction” in the Recording Preferences using various positive and negative values but this had no effect. Switching Software Playthrough on and off has no effect and Stop and Start Monitoring likewise has no effect.
Is there any way to remove this delay?

ASIO4ALL 2.14 as some posts on here suggest that it is solution but it had no effect.

Audacity doesn’t support ASIO, so that’s no surprise.

You have to listen to the iRig, not Audacity. Turn Audacity Playthrough off. Switch the iRig THRU/FX switch to THRU. That should/may give you the guitar on the way to the computer in real time, not the Audacity sound coming back with all it’s processing and delays.

If the real goal is overdubbing and playing to yourself, you may need to do that without hearing yourself. Full Theater Monitoring (live Instrument plus the backing track) depends on being able to hear THRU and FX at the same time. Try it. Sometimes the switch settings fib a little.

The latency setting you’ve been messing with controls the accuracy of New Recording matching the Backing Track. If you set that right, you don’t have to do any sync exercises when you overdub. Again, I’m guessing about the overdub thing.


Hi Koz, many thanks for your reply. I switched off Software Playthrough and set the THRU/FX to THRU. I now don’t get any guitar through my headphones - delayed or otherwise. I do a fair amount of playing in recording studios and when the engineer says to me “jam along to this” I plug into the desk and put the headphones on and hear the tracks plus my sound coming through, so I don’t think what I’m looking for is unusual. I’m not sure how to achieve the THRU and FX setting at the same time - on my IRig it is either one or the other. Are there some other switch settings that I need to look at?

on my IRig it is either one or the other. Are there some other switch settings that I need to look at?

Switch to a new interface?

Behringer UCA-202, for one example, supports hearing yourself in perfect real time and letting you hear the backing track.

The Behringer UM2 can play you to yourself and the backing track at the same time. Quite a number of different interfaces can do this trick. It is a pretty popular need.

I’m surprised the iRig won’t do it. But that’s the end of the world. You can’t listen to the computer without the echo and the only way to get rid of the echo is ASIO and Audacity doesn’t support ASIO.

If you find settings that work, post back.


I think the Behringer UM2 has everything you need. It has XLR microphone input, +48v Phantom Power option, Line In, Separate Instrument In and it will do a headphone theatrical mixdown both directions at once. Select DIRECT MONITOR.

Screen Shot 2020-05-01 at 15.16.58.png
That’s just an example. I know it works because I tried mine.


I remember going through all this. I think I had an iRig at one time. There’s no way to tell from the advertising literature whether or not the interface will do this monitoring trick. It’s rough going.


Hi Koz, Many thanks for your suggestions. I want to stick with the iRig as I’ve invested a log of time and money into it. I’ll try the IK Multimedia forum to see if anyone there has any thoughts.
All the best - stay safe!

Post back if you get something to work.