Invalid sample rate

So I’ve been recording for a few months without problems and 2 days ago Error code -9997 invalid sample rate came up. I checked that it was set to 44,100hz which is exactly what my AKAI Professional wants. I can only find info to identify the problem not correct it. I’d love some help!

OK, first try the MME and WASAPI hosts.

If this doesn’t fix the problem, then make sure all of your sample rates are the same. There are typically four of them of interest:

  1. Audacity default sample rate (lower left-hand corner).
  2. Audacity track sample rate - at left of each recorded track.
  3. Windows Device Recording sample rate - in the Windows search, type “mmsys.cpl”, then Recording > “your device” > Properties > Advanced > Default Rate.
  4. Windows Device Playback sample rate - ditto, but select the Playback tab.

Pick one, say 44100, try MME, try WASPAI; pick another, say 48000…

If still no cigar, try rebooting.

Thanks Jademan! I’ll give it a shot.

Jademan! I tried some of the more complicated things you recommended first, but eventually realized that I had inadvertently switched from MME to WASAPI. thanks for your help, I will go back to writing the great American metal song :smiling_imp: