Internal PortAudio error on Audacity 2.4.2

I am attempting to use an AT2020 USB+ mic to record vocals into Audacity, but I keep getting this error. I cannot record even using the built-in mic. I am on a mid 2015 i-Mac running Windows 10 64-bit. I have tried uninstalling and reinstalling, and I have made sure that I have set the privacy settings correctly and set my mic to be the default recording device. It can record into other software just fine, so I do not know what the issue is.

Are you getting the message “Internal PortAudio error. No Devices Useable” ? When audacity first starts up it scans all of your audio devices. Perhaps there is another device in your system that is causing the Audacity to choke. I wonder if “Disabling” each of your audio devices would allow Audacity to start up. If so, it might be a simple matter to find out which one is causing the problem. See also

If the error is on a specific device, try changing your Host selection. I hope this helps. :smiley:

So I disabled everything but my mic and my headphones, and it worked like a charm! Weird, considering everything else had no problem with it. Thanks for the help!

:smiley: Were you ever able to figure out which device was causing the problem ?