Internal PortAudio error. No Devices Useable.


I’ve been going nuts trying to figure this one out and I have no more in me. This problem has a mind of it’s own.

Audacity 2.4.2 for Windows 10

Every time I try to use Audacity an error box shouts at me with the error “Internal PortAudio error.” Upon launch no devices are applicable for use. Can’t record anything with audacity, can’t play anything back. Only editing. Happened when my audio drivers updated. Tried everything.

Lengthy Explanation
A while ago I had drivers I had to update. One of them was Realtek. As soon as I had finished installing them the provider name changed from “Realtek HD Audio” to “Realtek(R) Audio”. Everything was behaving fine except when I had to use Audacity for something, it would refuse to acknowledge any sort of driver I had. As long as I kept using my Realtek drivers, audacity would play up.

I reverted my drivers to some windows generic driver which my computer was warning me not to do. For a while I was happy using them, Audacity was working, my audio felt the same, maybe a little better. Most importantly, Windows was treating my headphones as headphones and not generic speakers.

I want to use my computers provided audio drivers. I was given options to tinker with my headphones, make them sound different which I liked. Sometimes I like the artificial bass, the virtual surround, etc etc. I was also able to use Stereo Mix. Overall it feels right using what I was given and what was working before doing some driver updates, something I’m always recommended to do on a daily basis having this mess up really throws a spanner onto my skull cause I can’t stop getting headaches trying to solve this.

I have reverted drivers, downloaded new ones where I could find any. I mainly used DriverFix. I’ve heard it’s considered like, adware or something stupid but me and my protection both agree it’s an alright program. More so, DriverFix helped me to repair an Alienware R13 or something, allowing it to do a Windows update it would refuse to do, sometimes hanging forever on restart or shutting down. It was like 4 months overdue from having the light mode update. It’s bad.

Right now I have used my PC’s driver disks to revert as much as I can to the factory recommended. Whatever installers are on there have access to the internet so I should be right to believe they’re updating from the source, an up-to-date version. No third party tinkering involved. Even threw in GPUTweak too, I had no idea I should be having that. I’m all up to date, using a good version of Windows and keeping Audacity updated. Whatever is happening is God’s prejudice against me so please help!!

I have tried everything on the internet to find a problem related to mine whose troubleshooting steps I can follow to resolve this. Uninstalling Realtek drivers to have them reinstall themselves. Updating drivers. I’ve ran the Windows troubleshooter. I’ve checked Windows update. Tried external programs. All this and then some, eventually reverted to disk provided drivers which communicate with the internet so I’m positive they’re the absolute up-to-date. So whatever I have ended up with, they’re what I would have had at the start.

My motherboard is an ASUS Prime B350-Plus

Thanks in advanced!

I assume that other programs can play audio?

Can you record with Microsoft Voice Recorder?

Yes, all other programs respond to my devices like normal.

Thank you for the suggestion too, as a matter of fact I did retreat to that recorder for one project. Unfortunately I’d prefer to stay on Audacity, I’ve got a lot more tools and freedom at hand to control where I save, how it sounds, trimming. I won’t bore you with every single detail as long as I’m trusted by my word that Audacity is necessary to me at this point.

Again, thank you! Any time is always appreciated!

If this is the correct motherboard, then there’s an Audio driver update " Version 6.0.8955.1 2020/08/27": Motherboards - All series|ASUS Global

Thank you again. Although as feared the problem persists and my drivers are up to date as per listed version. I have checked like before under device manager to ensure the drivers I’m using are indeed the correct ones and they are. I don’t believe it’s a driver problem now.

When audacity first starts up it scans all of your audio devices. Perhaps there is another device in your system that is causing the Audacity to choke. I wonder if “Disabling” each of your audio devices would allow Audacity to start up. If so, then it might be a simple matter to find out which one is causing the problem.

:blush: So, this just happened to me - and I wanted to share my experience. I got your error just as in this post: No sound

When this first happened, I plugged in my Bluetooth headset H10, then went back into audacity. I started playing, but of course audacity was playing through my earbuds which were sitting on the table, not my headset, so I couldn’t hear anything - duh! So I did a Transport > Rescan, so Audacity would know about my bluetooth headset. Instead of adding the headset to my available devices - it blanked them all out! (I don’t recall if there was an error message at this point). So I’m thinking what the …!

So I exited Audacity and restarted it and got the message on the above referenced post. No joy! Then I “Disabled” my bluetooth headset (as I recommended trying in my post above) - still no joy - AND WIndows continued to use it as my default output device - while it was disabled! I ended up powering the headset off.

I have no idea what happened! I powered the headset back on, re-enabled it and now audacity and everything else is working just fine. And audacity can play through my H10s bluetooth (as it once did in the past). Go figure! :smiley: