Installing GSnap

Hi, I’m a relatively new Audacity user and am trying to install GSnap, cos I don’t always sing in tune! I’ve tried to follow the various instructions in the handbook, but still can’t make it work.
I’m on Windows 10 (64-bit) and Audacity 2.4.1.
I’ve downloaded GSnap from a couple of different free sources. Qustion 1. Do I need the 32-bit version or the 64-bit? I read somewhere that Audacity is only 32-bit and therefore the 32-bit version of GSnap is required. (But Audacity is in my Program Files (x86) folder.)
I’ve unzipped the download Ok, though was a bit surprised to only find a .dll and a readme about the licence. I moved both of those files into my Program Files folder (just at the top level).
I then copied the .dll into the Plug-ins folder of Audacity (in Program Files (x86)).
I then rebooted the machine and opened Audacity. I was expecting to find GSnap or VST in the Effects menu, but no. Also looked in the Plug-ins menu in Audacity, and not there either.

What am I doing wrong?


Andy Mcw

I seem to have solved my own problem! Further to the above I did another reboot of the computer and re-start of Audacity. Then, looking in Tools/Add Remove Plug-ins, I saw that GSnap was now listed as a ‘New’ plug-in, with path = … Program Files(x86) \Audacity\Plug-ins\GSnap.dll;0 . (Don’t know where the ‘;0’ came from.) I clicked on it, and Enabled it. But at that stage it still didn’t appear to be active. So I did another re-boot and re-start.

This time it appeared at the bottom of the Effects menu - listed as Plug-in 1 to 1 > Hovering over the > then showed GSnap which I clicked, and there it was. finally. Somewhat tortuous, but I got there.

Hope this helps someone else get there quicker than I did!

Andy McW