Installer stops with Err.

After deinstalling old version and loading audacity-win-3.1.2-64bit.exe and running the installer, following err appeares: "System has said that audacity is still running and can’t be started twice. Use button new or open in your running audacity. But there is none running. Deinstalling again it showed “Audacity deletet, but some components not. Theay have to be deleted by hand”. Wich one and where? Installing again, massage came “File exists, overwrite?” Accepted with yes. Err “Audacity® Cross-Platform Sound Editor uses files which have to be actualized. Setup wants to close them automatically” After a long time “Closing not possible, do again/ignore error/break installation”. At least you have to break.
Which files have to be deleted to get new audacity installed?

Try rebooting the computer.

Hi steve, this I tried several times before writing to forum. Now no audacity is registered in the system (old uninstalled, new one ends with error). So I cant do any recordings. But an exiting option appearres: Clicking a file with the option “open with” audacity was offered and opened the file - and it was the new version. Amazing, isn’t it? So if I want to do recordings, I have to open an audiofile with audacity and then “open” to get an audacity-window for recording.
Lets hope that this stage lasts for a long time and functions also after Win-update or new audacity-version! :unamused:

The solution I practice since the error - couldn’t be accepted for a long time! It’s crazy to open a dummy-file to get audacity visible on screen, then click “new” to get an audacity to work with and afterwards close the dummy-audacity.
Is audacity not able to create an uninstaller which uninstalls all necessary files for installing a new version? :astonished:

Hi JupiNeu,
The version of ‘WINDOWS Operating System (WIN OS)’ you currently have? Is the current version of WIN OS an Upgraded OS from an previous WINDOWS Version (example: your computer has a Factory OS of WINDOWS 7 Operating System (x64) and you upgraded to WINDOWS 8 (x64) and then later on upgraded to WINDOWS 10 (x64) and then you allowed a WINDOWS UPDATE to download and install WINDOWS 11, or something not as grievous …)?
How did you do a “deinstall”? Are you aware that WINDOWS has a form of Program Un-Installation Process available through the WIN OS Control Panel? If so, Did you utilize it? Did you get every AUDACITY Installer from AUDACITY or a different source?
These are but a few questions that need answering as there is no mention of what, where, how in your information provided. Help the Audacity Forum Member(s) to help you … Work throughout the Audacity Forum in patience and consideration ’ need to know '.
It is strange that the Audacity Program provides the level of trouble you generally write about … Have you ever “RUN” WINDOWS “Clean Up” and performed a “Defragmentation” after the “Clean Up”?

Hope this helps you out.

Respectfully, ZARDOZ

Hi ZARDOZ, thank you for your reply. I tried to answer your questions attached in a PDF-file.
Installer stops with Err.pdf (97.7 KB)

Additional information: As I mentioned before, audacity isn’t registered in the system, but in Programs (x86) there exists an audacity-directory with the elements Audacity.exe, many .dll’s etc. I thought to find also a file like uninstall.exe, but it isn’t and I suppose there should be one.
Cound this be a way to get out of the crazy situation to copy a file like this from a friend and execute it in my audacity-directory?

Hi JupiNeu,
Are you on installation choosing an Directory other than the “Default” in which to install the Audacity Installation?
In a WINDOWS 64-bit computer: An x86 (32-bit Program/Application) usually Defaults to the “Program Files (x86)” Directory on the ROOT Drive whereas an x64 (64-bit Program/Application) usually Defaults to the “Program Files” Directory on the ROOT Drive.

Respectfully, ZARDOZ

Hi ZARDOZ, yes, I changed to x86 because the installer always breaks with error in the default directory and I thought this would help, but it doesn’t. Now I deleted the audacity-directory completely in x86 and installed again with the default :arrow_right: Audacity was installed without error!.
Thanks very much for this helpful hint!

Hi JupiNeu,
Glad the information helped your issue out of the situation. Take Care, JupiNeu.

Respectfully, ZARDOZ