Input volume slider says "Unavailable; use system mixer."

While I believe I’ve been able to adjust the recording level in the past using the input volume slider in Audacity 2.0.5, I now get the message “Unavailable; use system mixer.” Why isn’t it available? What is meant by “system mixer”?

I have the recording device set to “Digital Audio (S/PDIF) (High Definition Audio Device)”. If I open the Windows 7 Sound window and select Recording, I see that “Digital Audio (S/PDIF) High Definition Audio Device” is enabled and set as the Default Device. Properties>Levels shows the level to be set at 100%; however changing the level has no effect on the recording level in Audacity, which is too low.

Audacity checks to see if Portmixer works with the current hardware. If it does work, then the slider is enabled. If it doesn’t, then the slider is disabled.
I don’t know why Portmixer works with some hardware and not others.

Your normal operating system audio mixer (right-click the speaker icon by the system clock)

Audacity 2.0.5 is very old now. I suggest you try the current 2.1.2 release from Audacity ® | Downloads.

It’s unavailable because Audacity can’t directly control the recording level slider for the recording device currently chosen in Device Toolbar.

The “system mixer” is Windows Sound.

That is why the slider in Audacity is disabled - the Audacity and Windows Sound sliders should move in tandem, whichever slider you move.

What do you have connected to the S/PDIF input? Did you choose this input before now? It could be a driver problem. Assuming you have a branded computer like Dell, go to the web site of the computer manufacturer and look for current Windows 7 audio drivers for your computer model. If you have 64-bit Windows 7, get the 64-bit audio drivers.

If you built the computer yourself, go to the motherboard maker’s site to look for correct audio drivers.


Gale

You probably don’t want the S/PDIF input. That’s for a digital input, not a normal analog audio input.
What are you trying to record?

Sorry, I should have been more specific about what I was trying to do.

I am trying to record audio from the internet.
I have updated Audacity to the latest version (2.1.2)

3 choices are displayed under Audio Host: (1) MME, (2) Windows Direct Sound, (3) Windows WASAPI.

With (3) Windows WASAPI, 3 choices are shown for Recording Device:
(A) Speakers (Sound Blaster Audio Fx) (loopback)
(B) Digital Audio (S/PDIF) (High Definition Audio Device)
(C) Digital Audio (S/PDIF) (High Definition Audio Device) (loopback)

Using (A) sound is recorded but there is no input level control and the level is too low; using (B) or (C) no sound is recorded

With (2) Windows Direct Sound, 2 choices are shown for Recording Device:
(B)
(D) Primary Sound Capture Device

Both choices allow input level control, but no sound is recorded.

With (1) MME, 2 choices are shown for Recording Device:
(B) or (C) (I can’t tell which because the title is truncated)
(E) Microsoft Sound Mapper - Input

Both choices allow input level control, but no sound is recorded.

With the new version of Audacity, I no longer get the “Unavailable; use system mixer.” message; I just can’t move the slider.

How can I record with the appropriate sound level?

however changing the level has no effect on the recording level in Audacity, which is too low.

How low is it?

Don’t worry if you can’t adjust it. S/PDIF is digital so the recording level isn’t critical and you can use the Audacity Amplify effect after recording.

…If you’re connected to a DVD player lower levels are normal. There is usually lots of headroom in movie soundtracks and you may never hit 0dB if there are no loud sound effects.

The recording level varies between -30 and -18 dB. Even if the input is digital, if the recording level isn’t spanning close to the digitizer’s full range I would have thought you’re throwing away a lot of resolution.

In any case, though, it would be nice to have control over the input level, which I don’t seem to have now.

If you want to record from the internet, S/PDIF has no relevance unless you are running an optical output cable from S/PDIF out to S/PDIF in. Is that what you are doing?

Where is the internet playing? In Speakers (Sound Blaster Audio Fx)? If so, with WASAPI host, Speakers (Sound Blaster Audio Fx) should be your playback device and Speakers (Sound Blaster Audio Fx) (loopback) your recording device. Usually the WASAPI loopback recordings are at a fixed level, but sometimes you may be able to increase the recording level by turning up the playback level in the browser.

You may be able to record louder using analogue stereo mix of the built-in sound card, if you make the built-in sound card the Windows default playback device so that the browser plays to the built-in card. To see if you have built-in stereo mix, go into Windows Sound as described at the top of http://manual.audacityteam.org/man/tutorial_recording_computer_playback_on_windows.html.

Some SoundBlasters have “What U Hear” recording. If yours does, you may still have to enable it in the same way in Windows Sound. If it is not enabled there, Audacity cannot see it.


Gale

Sorry for not replying earlier, but thanks for the information and particularly the link you supplied. Things are at least clearer now. My sound card does not have stereo mix or What U Hear, but I find that I can control the record level by changing the volume level on the website (youtube) that I’m recording from. It’s still not as high as it could be even with the level at maximum, but it will do. Thanks again.

If you have copyright holders’ permission to record from YouTube, then you can download the video instead using web browser extensions or add-ons. This gives you the audio as it is in the video, bad or good, loud or quiet.

If you want to edit or extract the audio, install FFmpeg then drag the video into Audacity. At that point the video’s audio is exactly “as it is” in the video.


Gale

Thanks for the tip!