Input routing problem; recording Finale Notepad

I have Audacity 2.1.1, Windows 8.1, Finale Notepad 2012,on an Insignia tablet with just 1 micro-usb port. How the heck can I rout the Finale output (which normally goes to the headphone jack, using Finale’s Smartsound Softsynth) back to Audacity? Can I do this internally, or must I get an external usb A/D converter and rout it out of the headphone jack and back into the tablet?

Finale Smartsound does not show up in the drop down input menu for Audacity, and also not in the control panel>Sounds>recording tab. Thanks in advance.

Why not just “export” from Finale?

Well, Finale Notepad has no means of exporting audio from the synthesizer, just XML of the document. What I need is a way to rout the Finale audio to Audacity input, while it is playing.

Please be specific - from which synthesizer? Are you using a synthesizer module external to Finale?
How about: https://www.finalemusic.com/UserManuals/Finale2012Win/Content/Finale/Audio_Files2.htm

I agree it is better to export as Standard Audio File (WAV) but if the headphones port has the audio you want you can record the playback in Audacity:

  1. In Audacity, open Device Toolbar.
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Recording Device) box, choose the “headphones (loopback)”
  4. In the third (Recording Channels) box, choose mono or stereo.
  5. In the fourth (Playback Device) box, choose the headphones device that you are using for listening.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.

Gale

Thanks, Gale. Doesn’t work. Almost. In the second box, there is not the option for ‘Headphones(loop-back)’, only Speaker and Microphone (built into the tablet). It would work on Speaker if there wasn’t a hum generated internally by this rather cheap tablet; somehow it is using the same internal preamps as the internal mic, and the engineers maybe figured it was good enough for a hundred bucks.

Steve, Finale uses its own synth, downloaded with Notepad, called Smartmusic Softsynth. It is not connected to any synth other than that. I looked at the link, and Finale Notepad (free version) has no option to export audio. And Audacity has no way it seems to import it as an audio file, just as a raw data file.

I think the bottom line here is that I got a cheap tablet computer and I’m trying to do things it was not meant to do. Time to find another way to make money. I would still like to solve this, though, just out of curiosity.

So the tablet only has one audio port that works for both playback and recording? Even so, I am guessing it should work in principle as long as you choose the Windows WASAPI host in the first box.

The hum is analogue so might not necessarily be captured by WASAPI which is digital capture.

If you want to, post the complete information from Help > Audio Device Info… top right of Audacity.


Gale

Here it is. I was hoping It would be a simple solution, like maybe change or add a few HKEYs or something.

 192000
==============================
Device ID: 8
Device name: Speakers (Intel SST Audio Device (WDM))
Host name: Windows WASAPI
Recording channels: 0
Playback channels: 2
Low Recording Latency: 0.000000
Low Playback Latency: 0.003000
High Recording Latency: 0.000000
High Playback Latency: 0.010000
Supported Rates:
    48000
==============================
Device ID: 9
Device name: Speakers (Intel SST Audio Device (WDM)) (loopback)
Host name: Windows WASAPI
Recording channels: 2
Playback channels: 0
Low Recording Latency: 0.003000
Low Playback Latency: 0.000000
High Recording Latency: 0.010000
High Playback Latency: 0.000000
Supported Rates:
==============================
Device ID: 10
Device name: Microphone (Intel SST Audio Device (WDM))
Host name: Windows WASAPI
Recording channels: 2
Playback channels: 0
Low Recording Latency: 0.003000
Low Playback Latency: 0.000000
High Recording Latency: 0.010000
High Playback Latency: 0.000000
Supported Rates:
==============================
Selected recording device: 10 - Microphone (Intel SST Audio Device (WDM))
Selected playback device: 8 - Speakers (Intel SST Audio Device (WDM))
Supported Rates:
    48000
==============================
Available mixers:
==============================
Available recording sources:
0 - Master
==============================
Available playback volumes:
0 - PCM
==============================
Recording volume is native
Playback volume is native

You should never modify the Windows registry unless you know exactly what you are doing. :wink:

It would be better to show the complete information. We can wrap it in code tags so that it is in a little scrolling window.

Try selecting “Speakers (Intel SST Audio Device (WDM)) (loopback)” as the Recording device in Device Toolbar.


Gale