Input not recognised - help!

I’ve used Audacity for years with no problems: now after some months of not using, I can’t get it to recognise the input. I’ve tried rebooting the Mac and changing settings which have worked fine in the past, but no joy. Any help would be much appreciated.
Symptoms: Safari is playing audio from YouTube: output to the MacBook speakers is fine, but Audacity ignores the input. Click to Start Monitoring shows no input. Start Recording starts the cursor moving across, but no volume.
Audacity (v 2.3.3) settings: Recording Device: Loopback Audio; Recording Channels: 2; Playback Device: MacBook Pro Speakers. Transport Options: Overdub & Software Playthrough: both on.
Mac (v 14.5) sound: output set to Loopback Audio. Sound is playing well through the Mac speakers.
Loopback Audio (v 2.4.0): Sources include Safari (v 17.5); Output Channels show 2 channels; Monitors shows MacBook Pro Speakers. All 3 show the sound output levels correctly.
I’ve tried different combinations of source & output devices but no joy. Help please! Thanks
Alan Wilson

Does the Mac have permission to access the Loopback “device”?

I assume it must, since there are no errors when playing through Loopback and it works through QuickTime.

You could try updating to the latest version of Audacity. Version 2.3.3 is quite old.

Also, have you tried asking the folks at Rogue Amoeba if they can help?

I’ll try both of those. Thanks

Hi Alan,

Thank you for sharing this, I seem to be facing a similar issue :neutral_face:

While recording with Bluetooth device, the input device has been set within Mac and it shows inside Audacity, however on selecting the recording device to Bluetooth, there are no waveforms detected (like it’s muted). On switching recording device to Macbook Pro Microphone, it records just fine. I have tried testing this with multiple bluetooth devices, and across 2 macs. The issue still persists.

Details of Setup:
Audacity version: 3.5.1
Bluetooth Devices Tested On: Airpods, RealMe Buds Air3, Audio Technica ATH-S220BT
Running on: Macbook Pro M2, Macbook Air (OS Sonoma 14.5)
System Setting: Access granted for Audacity to microphone

While the bluetooth has been not working, I tried the SNOWBALL Microphone (Blue), connected via USB and it works perfectly fine.

If anyone has a fix for the bluetooth device, please suggest.

Thanks in Advance!

Grant access for Audacity to “Microphone” in the system settings.

Hi @mac-christian,

Thank you for your reply!

I missed out on mentioning - I have granted access for Audacity to microphone in the system setting. :+1:

Audacity is known to not play well with bluetooth audio devices.

I have this same issue. And… it is now also behaving same way on a new windows laptop. My 2¢ I think the music biz has convinced Apple and Microsoft to disallow headphone jack as an input source, to prevent recording from streaming music sources. I have reviewed some previous posts and did not see this, so forgive if it was in fact ‘out there’. It does still work on an older laptop, which I now have to keep forever… I have tried the rescan audio devices and verified the other settings against the machine that does work, all the same except headphone jack is not available as a source even after

The answer is simple (for me on a Mac, anyway): use QuickTime Player instead of Audacity to record streaming audio. Works seamlessly with Loopback; no problems. Then use Audacity to edit the recording. Pity it can’t all be done with Audacity, but that’s life.

This topic was automatically closed after 30 days. New replies are no longer allowed.