I have a MIDI file which I play through YAMAHA s yxg50 Soft Synthesizer
and listen in my old PC (windows xp sp3, AMD Athlon 2400+, Realtek AC97, speakers Altec Lansing VS4121).
I record the PC audio with Audacity (2.0.5. exe file, Selected capture device: 5 - Realtek AC97 Audio, host MME, stereo mix, proper volume and default settings, pc sound with no equalization)
and burn the WAV file to a CD, and then listen to it in a hi-fi equipment.
The recording of the orchestral sound is great, excellent you could say, not so brilliant as the midi file played through the soft synthesizer, which is a good thing though, as it sounds more natural (for instance the strings)

But I feel there is a slight difference in intonation (not bad in itself,but not the same). Not higher or lower in the general pitch, but different. A bit like watered off colours, or whiskey with a dash of water, and not pleasing in certain moments. I don´t find this problem in the PC execution (certainly others almost unavoidable, like lack of realism or balance, but not tiny discordant nuances)

Is there a way I could improve the WAV file resemblance to the PC sound which I find optimal?

I plan on getting a new computer though working still with SYXG50 and windows xp as I am very much satisfied with the musical qualities of the SYXG50 MIDI sound compared with the large (and expensive) orchestral libraries.

How can I improve my recordings ?
Should I buy some gadget (external sound cards, DAWs etc)?
Thanks in advance.

Your soundcard may be forcing the recording to go through twice.

The very best thing that could happen is for “Stereo Mix” to capture the playback sound on the way out of the computer as a digital signal and send it right back in to the record system still as a digital signal. You would be hard put to tell the difference between the captured recording and the first pass, primary playback.


Many systems allow the soundcard turn the show into analog and then redigitize it back into a digital signal. So the show you’re recording has been through two independent analog systems, each with their own distortion and shortcomings plus an extra analog to digital conversion. That’s probably where your sparkle went.

This is where I stand back and let the Windows people to take over. There may be a way to fix that.


Stereo mix will inevitably convert to analogue.

I hope these computers with Windows XP do not go online. You are exposing yourself to great risk now Microsoft has stopped issuing security updates for XP.

If you had Windows 7 or Windows 8 you could use the Windows WASAPI host and loopback input in Audacity which (I believe) is entirely digital. If the conversions to analogue to digital are the cause of the problem, try SoundLeech which is digital.

Also make sure you are not running any sound effects in your sound card playback and recording.


:smiley: Thank you so much for your time and feedback!

------Finally solved the problem. With my precambrian PC I can´t use the full potential of Audacity so I grabbed the digital signal with Free Sound Recorder in mono mix (stereo mix botches things up). Perfect intonation and brilliant sound. Much hiss noise though, but very much like a good analog recording transferred to a CD, so I don´t think it is a problem.
-------- Could not have done it without your help! I haven´t seen this problem adressed in recording and midi manuals (and I could not understand it), SYXG50 MIDI grounds me to XP and limits my options, but one should not surf the Internet with old tills!
Thanks again!

Do you mean you used SoundLeech? Let us know if you used something else because SoundLeech does not always work on all computers.


I can confirm that.

------------SoundLeech didn´t work on my computer, in spite of installing the version of the Microsoft Net Framework it delivered. Moreover it did detect the sound from the audio player (foobar), but not the Yamaha SoftSynthesizer S-YXG50, and in the first case I only got a file full of scratches. The above-mentioned is what I used. Volume 33, mono mix.
---------- The thing is, the Yamaha EXtended General MIDI I use is very difficult or impossible to implement in later versions of Windows, even with xp compatibility. If in order to the play the score (score-editor file) I use different SoundFonts, synthesizers, orchestral libraries, no matter how good they are, , the result is entirely different! It is a tiny bit like choosing a great non English speaking actor for a play in English!
---------- It does look like using Audacity with the WASAPI host solves the XP audio extraction problems (
Thank you so much!

You mean you used ? As far as I can tell, that isn’t digital and requires an anlogue recording device like stereo mix or wave out to record computer playback.


-------That´s correct, but I don´t know what it does. No distortion problems like before but a fair amount of background noise. Recording mixer: mono Mix. Recording device: Realtek AC97 Audio.
--------I am really bound to the limits of XP. If I played the midi data from the musical editor score with another wavetable synthesizer in Windows 7 or 8 I could reap the digital input with Audacity, but the sound would be different.
------- I have also tried Virtual Audio Cable (recording with Audacity) but no way (no input).
-------Thanks for your patience!

Back in 2002 they had the same problem
The “pro”, super noiseless solution? Get a software that can record or “grab” the digital data stream that reaches the Digital to Analog Converter input of your soundcard. Something like a logical Y splitter. One part goes to the DAC, the other to your disk.

What software does this? Beats me…

It’s clearly using the built-in Realtek device so as described, I don’t think that is digital.

Does Audacity offer mono mix as well as stereo mix when you look in Device Toolbar? Or if you record from stereo mix in Audacity but change recording channels to 1 (mono) does the problem go away?


-----------You hit the nail on the head! Audacity —OUT Realtek AC97 —IN Realtek AC97 Stereo MIx —and 1 mono channel. Problem fixed. No noise at all , perfect intonation and clarity of parts and no distorsion.
-----------I think I ruled out that option (it was always displayed) due to the resulting low energy waveform. I pumped up the input fairly and now I have a beautiful recording. Thanks for your time and patience!