Importing raw wav from Ableton rec that went wrong

Hello there

So, last night we had an amazing gig with my band, and we wanted to do a multichannel recording of it using Ableton 9 in a fairly old laptop that the vocalist had. So during the rehearsals I connected the behringer x32 to the pc, then mapped the inputs and I clicked the rec button. Everything went smoothly (no bad wav files).
However, yesterday (day of the show) for some reason the recorded files became corrupted.

I found out that all the wav files were there, in the project folder, with a completely normal file size. They just dint play because they didn’t have correct encoding (or no encoding at all ~ i dont know if that’s possible).

I tried importing the wav (~30 min long) into audacity from file → import → raw file and I found out that 48000Hz signed 24bit pcm was the closest to getting it to play at normal speed. However there was a lot of audio clipping when the actual music comes in.

Here is a corrupted file from one track of that project (~190mb):

I tried almost every available codec in Audacity without any luck.
Any help would be much appreciated.

Ableton 9

What did Abelton say it produced? Do you still have access to the instructions?

If the recommendation fails, then the corruption may have partially scrambled the file header(s). That’s rough to fix because Audacity can deal with broken files or healthy files, but not ones that are partially, sorta damaged.

I can’t look at the file right this second.

Do you have any idea what happened?


Got it! (I think… I didn’t actually listen because I’m at work but it looks like a waveform.)

24-bits with an offset of 1. 24 bits is 3 bytes and if you start on the wrong one, the 24-bit samples are re-assembled with the wrong bytes in the wrong order. An offset of 4 or 7, etc., will also “work”. You’re just throwing-away a couple of bytes. (The first several bytes in that particular file are zero anyway.)

If the files are truly corrupt, the other files may need a different offset, but 0, 1, or 2, is all you need to try with a 24-bit mono file.

They just dint play because they didn’t have correct encoding (or no encoding at all ~ i dont know if that’s possible).

There is no WAV header. That might be normal with a “raw” Ableton file before you export to a particular format.

I think it needs an offset of 2.

Holly shit! that worked!! Thank you so very much

raw import.png

Very grateful to the people who pitched in on this thread as I was able to make good progress after my laptop abruptly went off and messed up the recorded files from an ableton session…

I was able to get the files to sound like the music we were playing but the noise level is really high and there is some randomish distortion, sounds kinda cool and all but I’m wondering if anything else can be done to get it to just clean sound clean.

I used
Signed 24-bit PCM
Any byte order I’ve tried and it made no difference
An offset of 1 (any other number other than 4, 7 etc.) resulted in plain noise.

Any help would be much appreciated!

Thank you

Not if you don’t post a sample. Note that the default sample rate for the behringer x32 may be 48000.

I’m having a similar issue. We recorded a live performance for a video we are making but when I opened the session the files were missing. it turns out somehow they were deleted from my laptop. So I recovered the files but when I went to play them back you could only hear partial parts of them and the rest is filled with noise and loud distortion. I’ve tried everything I could think of and imported raw data into audacity with different offsets and nothing worked! If anybody could help it would be much appreciated, a lot of time and money went into making this video and I really don’t want to mess it up. Here’s a link to the audio

I think that recording is toast. Even the “good” parts are massively overloaded / distorted (recording level far too high).

What did the folks at Ableton have to say?