import m4a, export wav; Zoom H4n says "Invalid File!"

The first file I imported into a new project was m4a. I exported the audio as wav to use in my Zoom H4n. The H4n looked at it and said, “Invalid File!” I tried exporting with different bit rates and different metadata, no luck.

With exactly the same content, I started by importing an mp3 first. Then the H4n was fine with the exported wav.

Any ideas what it didn’t like and why Audacity put it there? Looking at the file properties in Windows, I don’t see anything different–nothing hiding in the Origin or Content properties.

(version is 2.3.2)

Aha! The Zoom support guy asked about bit depth and sample rate, and it took a couple false starts but I finally found that the m4a files causing the problem were sampled at 22050 Hz. When I import one of them into an empty project, it changes the project sample rate.

Is there a way to make the sample rate sticky, so it doesn’t change when the first track is imported? Or at least get a warning when it’s changed? I’m not spotting any options under Quality, Import, or Warnings.

You might get a lot of warnings. Audacity changes the bit depth when you import something. My guess would have been that Audacity didn’t change it and you tried to apply a 22050 Hz based file to the H4n. It may not like that as the sound fidelity wouldn’t be very good.

I opened up the H4n instructions and I see no reference at all to support for sampling frequencies lower than 44100 Hz.

A show recorded at 22050 Hz would have sound quality better than AM radio, but worse than FM.

I started by importing an mp3 first.

There is a caution about doing production with MP3 files. MP3 gets its small files by carefully damaging the sound in ways difficult to hear, but the damage is there. If you make an MP3 from an MP3, the damage gets worse. Nobody makes it to the third MP3.


Yeah, not my own source files–I work with what they give me! m4a is compressed as well, so I have the same issue there. The 22kHz ones are alto voice only, so the loss of highs isn’t too terrible.

The project rate changes only when the first track is imported. I don’t see anything to indicate bit depth is a property of the project–it’s associated with each track individually. The export dialog asks me to select bit depth, but not sample rate. It’d be nice to be able to select it there directly rather than having to change the project rate, but even then I’d still like to set the project rate permanently before importing any tracks.