iMac, maverick, audacity not working

I cannot get Audacity to work on my new iMac. There is no microphone jack, so I purchased a radioshack USB microphone input device.

The device appears to function. The microphone light is on.

The sound preferences show usb headset not microphone. Same with audacity.

I have used Audacity successfully for a long time on my prior mac, without difficulty.

I am trying to record from a phone line, using a radioshack telephone recording device. Again, it always worked on the former mac.

Will Audacity work on my new iMac and if so, what do I need to do to make that happen?

Thanks, Deb

Audacity is a slave to the computer it is running on. If you can’t see a device in System Preferences > Sound then Audacity won’t see it.

I am successfully running Audacity under OS X 10.9.4, so that is not your issue. Your issue is getting your external sound input devices to work with your iMac. Once they work with the iMac they will work with Audacity.

What model of radio shack microphone input device? How does it connect to the iMac? What are you plugging into it?

“USB Headset” usually means microphone plus headphone (like one would wear for a VOIP phone call).

What model of radio shack telephone recording device? How does it connect to the iMac? How does it connect to the telephone?

– Bill

Thank you for giving me hope that I can get Audacity to work on the new iMac.

I am connecting to the iMac with a Sabrent USB 2.o Stereo 3D sound adapter (model USB-SBCV), with a microphone and headphone connection. I am plugging the microphone into the microphone jack. But all the computer sees is the headset.

I am connecting to the to the phone with a Radio Shack telephone recording control, cat no. 43-228A. I have used this recorder with my other mac and it works fine. It connects to the land line phone between the cable from the wall and the phone. From the wall goes into the phone in slot and to the phone goes into the phone out slot. It still works. I tried it again on the other mac.

I think the problem is this Sabrent device.

What do you use?

Thanks so much.


I can’t tell where they’re getting this “3D” thing from. It looks like a normal headset adapter like my Startech units.

Close Audacity.
Unplug, wait and plug the adapter into the Mac with no other cables.

Apple (upper left) > System Preferences > Sound > Input. My adapter shows a record USB device (attach). What does yours say?

Screen Shot 2014-08-12 at 8.32.45 PM.png

Mine says “C-Media UB Headphone Set” even though it’s a microphone/headset combo device.

What device are you using? I have no qualms about taking this back to radio shack and ordering something else that I know will work.

Thank you.


Does it see that in the INPUT side of the System Preferences panel? That name doesn’t necessarily mean anything. That’s just whatever the manufacturer of the chip thought might be informative. Some of the higher end makers burn their own name on there. Some leave the chip default name (USB AUDIO CODEC).

If it shows up in the System, then it’s available for recording. Launch Audacity (or restart it — that’s important) and the same or similar thing should show up in the device toolbar.

Select it and click once in the red recording meters to turn them on in test mode.

Talk. Does the red meter bounce?


Hello Koz,

No, after relaunching, the red meter does not bounce, nor will Audacity record.

Yes, that is what shows up on the input ice of the sound preferences panel.

What device do you recommend?