I Need USB Microphone Help!

I’m trying to record some tracks with a Logitech USB Microphone onto my computer, which is Windows XP. When I want to record, Audacity isn’t even recognizing that there’s a microphone at all and doesn’t give me an option in the dropdown box next to the microphone icon. This dropdown box is disabled, I can’t even click it.

Help please!!

  1. Make sure that the microphone is plugged in and recognised by Windows before you start Audacity.
  2. Open Audacity and go to:
    Edit menu > Preferences > Devices (“Audio I/O” in the old 1.2.6 version)

Set the recording and playback devices there.

Okay, Windows is recognizing my microphone and it’s in working order. I tried fixing the preferences as well, and restarting my computer, and neither of those solutions worked.

Does the microphone work with Windows Sound Recorder?
Which version of Audacity? (look in the Audacity “Help menu > About Audacity” for the exact version number).
What do you currently have set in: “Edit menu > Preferences > Devices (“Audio I/O” in the old 1.2.6 version)”

The microphone does work with Windows Sound Recorder. I just tested it.
I’ve got Audacity 1.2.6 but I also downloaded the Beta version and I’m having the same problems with it.
My recording device is set to Logitech USB Microphone and 1 (mono) channel.

Half-way there. 1-channel (mono), 16-bit, 44100. My USB microphone will only work with those settings.


Alright, I tried your suggestion for the settings and still no response. It worked for a moment and then stopped again. What could possibly be wrong?!

In Audacity 1.3.11, go to “Edit menu > Preferences > Devices” and set the Host to MME and the Recording device to Microsoft Sound Mapper.
Set the playback device to your sound card.