I need to have IMA ADPCM codec, does Audacity have this?

At this time I’m searching for voice over recording software for use on my iPad. I’m a voice talent. I have a telephony client whose phone system requires .wav files which are: IMA ADPCM codec in addition to being 8000 kHz, 4 bit, mono.

My current recording software’s .wav files cannot be loaded into the client’s phone system even tho I’ve recorded at 8000 Hz, mono. I’ve checked with recording hardware folks and they tell me that my Apogee Mic is well up to this task and that it’s a software problem. Hence, I need to find a recording software which meets the client’s needs. Can Audacity do this?

I’m not technologically sophisticated, so please keep your responses to me in plain English.

Thanks. Any and all help will be appreciated.

Apparently, that’s one of the Export formats that Audacity supports if you add the separate FFMpeg software.


It’s also good to be in at least Audacity 2.0.3.


And it’s “voice-over.” How will we respect you if you go around hyphen-free?


Audacity can export in IMA ADPCM format.
In the export dialogue screen you need to select “Other uncompressed files” as the file format, and then click the “Options” button to set “WAV” as the “Header” and “IMA ADPCM” as the “Encoding”. See here for more information: http://manual.audacityteam.org/o/man/file_export_dialog.html

To make the exported file have a sample rate of 8000 Hz, you need to set the “Project Rate” to “8000” before you export (bottom left corner of the main Audacity window.)

If that is your search, Audacity cannot help you because it requires the Mac OS X desktop operating system. Please see: Audacity Manual .

You could search on the Apple iPad store: Music - App Store Downloads on iTunes .


Thank you for letting me know that this isn’t available for my iPad.

I’ve downloaded Audacity 2.0.4 and installed it onto my Windows laptop. I have also downloaded the FFmpeg additional software for windows. I’ve recorded my file as an 8000 Hz mono and have exported the file. When exporting, I selected “Custom FFmpeg export” and clicked on OPTIONS. In OPTIONS I’ve selected: (show all formats) wav , (show all codecs) adpcm_ima_wav and (general options) bit rate = 4 and sample rate = 8000 Now I’m trying to attach the file to an e-mail to send it to someone. It attaches to the e-mail fine. The person receiving the e-mail can’t open the file and listen to the recording. They are asked to “Choose the program you want to use to open the file:” Which should they use? (I tried to open it with ArcSoft Total Media but it says this file type is “unsupported.”)

What am I doing wrong? The client needs a file which is “IMA ADPCM codec, .wav, 8000 kHz, mono, 4 bit” … am I doing the export function correctly?

Please help.

You are not following the instructions that I posted here: I need to have IMA ADPCM codec, does Audacity have this? - #3 by steve

What am I doing wrong?

Prior to recording I’ve set Audacity to 8000 Hz (lower left) and mono (center upper). During the export function I’m again specifying 8000 Hz and 4-bit in the (general options) section of the OPTIONS. Is this possibly a duplication of effort since I’ve already set it to record at 8000 hz?

Once again, I’m not technical, so please don’t lose patience with me.

The important thing is that the “Project Rate” (lower left corner of the main Audacity window) is set to 8000 immediately before you export.

Then go to “File menu > Export”, which will open the Export Dialogue: Audacity Manual

In the Export Dialogue, select “Other Uncompressed File Types” as the export format.

Then click on the “Options” button to bring up the “Uncompressed Options” dialogue.

See here for information about these options: Audacity Manual

Set “WAV” as the “Header” and “IMA ADPCM” as the “Encoding”.

Then continue with the export.


A step by step is available on this log



For completeness, it may be worth adding the steps to your blog for converting from stereo to mono (for the case where someone may be starting with a stereo file).
There are two ways of doing that:

  1. “Tracks menu > Mix > Mix Stereo down to Mono”
  2. Split to mono, then delete the unwanted track.

The difference between the two methods is that the first produces a mix of left and right (this is usually the preferred option, but may sound peculiar in the case of a few unusual stereo tracks). The second gives you either the left channel as a mono track, or the right channel as a mono track.