I need help recording stereo mix


I’ve tried Audacity and a bunch of different programs that use Stereo Mix to record audio and all I get is a faint static. I’ve checked the settings on Audacity and Stereo Mix and nothing seems to work, and I haven’t found any useful advice on the internet. I’ve also tried programs that recorded directly from the headset (the playback device, not the mic) but found none without limitations on the free trial, such as 2 minutes max.

I’ve spent a couple hours now just trying to record one thing and I’m growing tired of trying to find the issue, so I figured if anyone wants to be super nice and record it for me, that’d be neat. It’s three tracks, about 20 minutes in total, and you could just record it as one .wav or .flac and I’ll split it and remove the silence. I’m gonna convert it to 320kbps mp3, 44100 kHz (or 48000 if that’s preferable, but do tell if so) so any quality settings that work well with that are fine. 100% volume throughout is of course preferable.

The tracks can be found here; all three tracks (The Hatemongers, Horror of Warefare, Marquis De Sade) of Morriah - Let The Sword Descend.

If no-one wants to do that or it’s against some policy I’d appreciate any help you could offer with the Stereo Mix issue, or a recommendation of a free program that doesn’t use it.

Which Windows? Not all Windows machines can self-record and they don’t all call the service Stereo-Mix. Self recording is a dance between Windows, the soundcard and the soundcard software or drivers. If any one of them drops the ball, then the service fails.



Sorry, I forgot to include that in the OP. Windows 8.1 64 bit, motherboard ASUS P8Z77-V, and I installed the drivers just tonight: Realtek Audio Driver V6.0.1.7023 for Windows Win8.1 32bit & Win8.1 64bit.(WHQL)

We won’t record for you because we don’t have the permission of the copyright owner, amongst other reasons.

If you are using a USB headset you cannot record this directly using Stereo Mix of the built-in sound card, because the headset is a different audio device.

Have you read http://manual.audacityteam.org/o/man/tutorial_recording_computer_playback_on_windows.html ? As you are on Windows Vista or later you can use the Windows WASAPI host choice in Audacity’s Device Toolbar to record computer playback of the USB headset or any other playback device.

  1. Open Device Toolbar .
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Output device) box in Device Toolbar, choose the Speakers or Headphones that you are using for listening.
  4. In the third (Input device) box in Device Toolbar, choose the (loopback) input for the same device you chose in step 3. For example, if you chose “Speakers” in Step 3, choose “Speakers (loopback)” in this step.
  5. In the fourth (Input Channels) box in Device Toolbar, choose mono or stereo.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.


Thanks. It worked with WASAPI and speakers, whereas with headset (USB) I got an error message when I tried to record; something like “please check recording device and sample rate settings” I think. I also got some weird skipping in the beginning whenever I recorded something, but I worked around that by playing something unrelated for a couple seconds and then what I actually wanted to record.

That’s usually the case if you have different sample rates in Audacity and the sound-card. Wasapi works only with 44.1 kHz flawless. Ensure that this sample rate is also used in the sound control panel.

I changed my speakers’ default format (bit rate & sample depth in shared mode, whatever that is) from 24 bit 48000 Hz to 24 bit 44100 Hz, and that fixed the skipping. What does the bit depth do? Should I change it from 32 bit float to 24 bit in Audacity to match the speakers? Also, when I’m just listening and not recording anything, is there a difference between having 44100 Hz, 48000 Hz and 192000 Hz on my speakers? More resource craving? Any audible difference?

By the way, I tried changing the project rate in Audacity (with Wasapi) to 96000 Hz and it seemed to work fine.

Did you set the output and input devices in Device Toolbar to the USB headset?

It may be best as Robert J.H says to set the Windows Default Format for the headset to 44100 Hz.
To do that, right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the headset then choose “Properties”. Then click the “Advanced” tab and set the Default Format. Also on that “Advanced” tab, you could try enabling the two “Default Format” boxes or not - that feature may not be working exactly as intended with Audacity.

Set 44100 Hz Project Rate bottom left of Audacity too.


Yeah, I tried all that, but still no luck with the headset.

You can read here about what Shared Mode and Exclusive Mode mean: http://wiki.audacityteam.org/wiki/Windows_7_OS#sample_rates . That applies to Windows 8 too.

As I said, these modes may not apply correctly to WASAPI recording in Audacity yet.

Greater bit depth gives the possibility of greater dynamic range. If you are recording a web stream it is probably only 16-bit.

If in Windows “Sound” you enable those “Exclusive Mode” boxes underneath “Default Format” then Audacity “should” under WASAPI ignore the sample rate and bit depth specified in Default Format and request the rate and bit depth directly from the device. But currently I don’t think Audacity does ignore the Default Format sample rate and bit depth under WASAPI.

For both computer speakers and headset I would enable Exclusive Mode or not according to what works best.

If Windows is doing any processing of the audio it will upconvert from 24-bit to 32-bit anyway before sending it to Audacity, but these matters are really only for audio engineers. I would leave Audacity Default Sample Format at 32-bit float unless you have reason not to.

Higher sample rates will put more strain on the computer, yes.

Mismatched sample rates between Windows and Audacity “may” or “may not” cause distortions or speed problems.

Most humans can’t hear higher than about 20000 Hz which is easily contained by a sample rate of 44100 Hz.

It may or may not do. For WASAPI the general recommendation is to stick to 44100 Hz, both in the Audacity project rate and in Default Format in Windows.


Experiment. WASAPI loopback mode in Audacity has been reported to work with USB headsets and headphones.

Try 44100 Hz in Audacity Project Rate and 44100 Hz (16-bit or 24-bit) in Windows Default Format (try Exclusive Mode on or off).

Make the USB headset the Default Device in Windows “Sound” (right-click over the headset).

After making changes in Windows “Sound”, do Transport > Rescan Audio Devices in Audacity.


Still no luck, but since it works with the speakers I don’t feel a tremendous urge to solve this mystery. Thanks for the help.