I NEED HELP, nothing is recording!

Ok so after months of working on getting a new desktop that runs Windows 7 since thats the OS i know will run most of my recording software without a problem, I get ready to finally start back up recordings and i have to reinstall Audacity, the new current 2.1.1 version and thus begins a half hour of frustration as nothing is going from my mic into Audactiy and ive tried both front and back ports, set my mic as a line in and still nothing is getting picked up. I really dont want to have another setback after ive worked so damn hard all year to get to this point just to have to postpone projects again

What’s the microphone? Type and model number?

What’s the show? AudioBook? Music?

We live in good rich details.


Its a studio grade mic, the only numbers i found on it are BM-700 and im just trying to record commentary for Let’s Plays on youtube and tonight was supposed to be my desktops test run with that. I even just tried a Logitec headset i had that i know works and Audacity was still not picking anything up. I know if i tried using Audacity i have on my Hp laptop it’ll work but i installed it the same way i always do so i dont know where i went wrong, it even gave me a popup that installed the lame.dll thats needed to record

We may need to wait for a Windows elf to help.

The BM-700 appears to be an analog microphone. How do you have it connected to your computer? USB microphone adapter? They obliquely tell me in the instructions that the microphone needs phantom power, so is there a box in the middle you left out?

The computer connection is really important to settle before we start troubleshooting.


installed the lame.dll thats needed to record

Lame isn’t needed to record. That’s the software that makes an MP3 after you’re done.
I don’t remember my Audacity 2.1.1 doing that…


no theres no power source needed on this mic, its a plug jack mic, like to kind you have on earphones so any power that the mic needs comes from the comp. And it was a fresh install onto this desktop so i think thats why the lame.dll thing popped up for me

Then it’s down to Windows recognizing it and then Audacity.

This one?


One of the comments solved it:

All you have to do is plug the mic into the mic port on your computer

That doesn’t appear in the instructions.

We have generic tutorials.



I know under certain conditions you have to make changes to Windows as well. The Windows people will be along. I’m a Mac elf. I’m also at the western edge of the 9 time-zone support system and I have to leave soon.


Yeah thats the exact thing i got sitting next to me. It works with my Windows vista and 8 laptops before without needing any sort of setting changes, ive no clue as to why windows7 needs a setting change for this to work

And you’re talking to a Mac elf, so this may remain a mystery for a while. I did have to run a Win7 machine at work and I thought it ran pretty well.

I do know you select recording devices in the Audacity Device Toolbar.


I have gotten into trouble by having Stereo/Mono set wrong.


That’s from the on-line manual.



Audacity does not see a new mic that you plug in after Audacity is already open. Have you tried restarting Audacity or using Transport > Rescan Audio Devices at the top of the Audacity window?

If that does not help, the mic may not be enabled in Windows Sound. Follow the steps in this Windows Sound link, starting with "Recording Settings: Right-click anywhere inside the Recording tab and choose “Show disabled devices” then right-click again and check “Show Disconnected Devices”. Then right-click over the mic and enable it.

If you are still stuck after that, open Help > Audio Device Info… at the top right of Audacity and click OK in that window. This opens a window to save the audio device info as a text file. Attach that text file so we can see what devices Audacity sees. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1


Audacity does not see a new mic that you plug in after Audacity is already open.

This thing isn’t a device. It’s an analog microphone plugged into the soundcard which never goes away. It shouldn’t be necessary to juggle devices in my opinion. The soundcard should be default.


working on getting a new desktop

Unless it’s broken. There is no evidence the soundcard on this machine ever worked.

Did I hit it? It should not take sweating blood to bring up a Win7 machine…if everything is working. We can’t help you with the hardware. Sorry.


Yes I should have qualified that as “not necessarily” in the case of a computer mic with a TRS plug.
Ideally you “should” even be able to plug the mic into the external mic jack of the computer while Audacity is recording and it just starts to pick up the mic signals in that track.

But note, all built-in inputs on Vista and later are separate devices as far as Windows is concerned. So “ideally” means if the external mic device is actually enabled, and if there are correct and up-to-date drivers for the built-in sound card. :wink:

We’ve seen plenty of times where rescan of devices or restart of Audacity is needed for adding a computer mic. I’ve even known bad drivers to cause hot-plugging a mic to disable it.

A new Windows computer or new Windows installation may come with only the internal mic device enabled. That is very common.

So hero361 does need to:

  • check that the external mic is enabled in Windows Sound
  • (might be necessary with imperfect drivers) right-click over the mic and choose “Set as Default Device”
  • Transport > Rescan Audio Devices or restart Audacity after enabling the external mic in Windows Sound
  • then use Device Toolbar to choose the external mic as recording device.

If you make the mic default device in Windows Sound, you can also choose “Microsoft Sound Mapper - Input” (with MME host) or “Primary Sound Capture Driver” (with Windows DirectSound host) as the recording device in Device Toolbar.


Ahhhhh i found out why i was having trouble. The guy who put my comp together had put in a RealTek HD Audio Manager program with the sound part of my comp. It wasnt set up to record things off the bat and that tripped me up until i tinkered around with it somemore, it has a decibel increaser thing when i set my mic to Mic In rather than Line In like it used to on my HP laptop and it was set to flat zero, making me sound like im trying to speak to someone 20 feet away or just a straight flatline. I bumped it up to at least 20 decibels and sure enough Audacity picked it up as normal, wish i had figured this out last night for Destinys Sparrow Racing event. But thats what i get for getting a gaming comp built without diving deeper into its inner workings, Still I really appreciate the help you guys and your response time too is top notch

That’s the microphone 20dB Booster. Yes, that can be the difference between getting a good volume recording and not.

Glad you resolved it.


It can be difficult sometimes to see if you are recording a flat line or the proper audio but just too quiet. From your description we thought you were not recording the mic at all, but to check that any time, just use Effect > Amplify… and OK which makes the audio as loud as it can be.