I have suddenly got lots of echo on recordings

Windows 10 with Audacity 2.4.2

I have used Audacity successfully for years. This morning the recordings when played back were much louder than they had been and had a lot of echo. In effect, they were unusable. I record from the BBC iPlayer streaming feed. The sound directly from that source is fine.

My settings were:
Windows WASAPI
Speakers/Headphones (Realtek Audio) (loopback)
2 (stereo) recording channels
Speakers/Headphones (Realtek Audio)
Project rate: 44100

To try to resolve the problem I downloaded and installed the latest version of Audacity.
With the above settings it records but when I try to playback/edit it now says:
“Error opening sound device
Try changing the audio host, playback device and the project sample rate”
When I change to MME it will now play but still has the problem of echo.

I am not aware that I changed anything overnight nor was there a Windows update.

Turn off [u]Software Playthrough[/u] when recording “loopback”. It creates an internal feedback loop.

I have checked and it was unticked.
I disconnected the speaker/headphones jack and reconnected it. That seemed to get rid of the echo.
However last night after that recording using MME was much too faint to be usable. Using Windows Wasapi worked well on recording but not on playback. For that using MME was fine.
After shutting down the computer overnight I tried again this morning and the same problem was there with the first two recordings. Then, without my knowingly doing anything, both recording and playback work using Windows WASAPI. The volume has also become much louder.

For the moment, I am happy but it is difficult to type with my fingers crossed.

John Carmichael

Beware of “voip” apps (such as Skype / Zoom). They can change the Windows sound settings without your knowledge.