i can't record using headphones having a trrs on my laptop

Hi there,

I got a new laptop. It has a combined jack entrance, trrs it’s called i believe.

Now when i want to record a audiostream from the internet, whilst using my headphones (with or without mic), i can’t choose “Headphones” in Audials.
And thus i can’t record audio while listening to it on my headphones.
I could of course do it via the speakers, but this not always appreciated around me :wink:
I tried every combination in MME, Win Directsound and Win WASAPI)

I have a windows 10 laptop with realtek audio.
I use audials 3.1.3 ( the Donald Duck version :smiley: )

I tried searching the internet for an answer, but i failed.

I hope to find the answer here.

audacity mic line.png


Tip Ring, Ring, Sleeve.

Screen Shot 2021-12-25 at 11.23.56.png
That means the microphone and headphones are jammed into the same connection. This should not prevent you from recording on-line content, although it might be a little bit of a juggling act.

Some computers record YouTube shows by telling the computer to Record Everything. Everything includes your recording connection, now part of the TRRS. When you plug something into the TRRS, you obviously want to use those services and none of the others (the computer thinks to itself).

There should be a setting in the Windows Control Panels that allows you to split the microphone from the rest of Windows Services. Someone will post. I’m not a Windows elf.

Oh, and because this isn’t complex enough, not all computers wire the TRRS the same way (above).


Hi there,

Somehow today in Audials, Headphones is shown .
I don’t know what happened, apart that i started problemsolver for audio, which showed headphones, which were plugged in, but there were no problems so i didn’t do anything.
Then i opened audials and presto.

I guess i solved the problem :laughing: