I can't import music for background of voice HELP

I am having trouble importing Mp3 music files into my Audacity for a background on my voice recording. Some of my music will import but 99% won’t. I choose the “Music” folder where I have downloaded many CDs, I go to the CD and the song I want, double click on the song and then I get the Audacity message saying it’s patented and can’t be imported. But practically every CD made is patented, how can you import a song from a CD you’ve downloaded into your Media Player on your Windows computer. The tutorials all make it seem so easy, they never get a Can not import message on anything they import, it’s practically all I do get. :confused:

I choose the “Music” folder where I have downloaded many CDs

I think you may be missing an important word. Music on a CD isn’t in sound files. If you want to get the music from a Audio CD you have to “rip it” into sound files. Those should come across as perfect quality WAV (Microsoft) because that’s the native format of the sound on a CD. All the rip software does is scoop the data off and plunk front and back labels on and other file information. If you have the sound as lesser quality MP3, then somehow you also converted the music from WAV to MP3

This can get a little wacky because of Windows insistence on hiding the filename extension. Hiding the extensions is OK until something goes wrong.

I think this works for Win7.

Hidden File Extensions - Windows
– Start > My Computer > Tools > Folder Options > View > [ ] Hide Extensions for Known File Types (deselect)
– Apply (to this folder) or Apply to All Folders
– OK

It’s not unusual for posters to arrive with question marks floating over their heads. They think all sound files are MP3 and they think the files they have are MP3s. They can’t tell the type of file they actually have without the extension. MyMusic.wav or MyMusic.mp3.

Which ones do you have?


Hmm, you already stumped me at go to “My Computer”. When I go to “Start” there is no “My Computer” option to go to much less Tools to see. When I hit start I do see a “Computer” option, but when I click on it there’s no “Tools” option.

I downloaded many CDs and have had no trouble playing them or transferring them to an Mp3 “Walkman” but when I try to import a song from my “Music” section where all albums and songs are seen, I can’t import. Now I am able to import a song I recorded directly off a website by using Audacity and hitting the record button there under the “Windows Waspi” box, music I live recorded from the computer I put in a separate folder and there I can import music. But I only have a few songs there that are instrumental and I have 100s of instrumentals to choose from in my regular CD downloads “Music” file.

Those tutorials make it seem so simple, “Import and select the song you want and double click on it”. Not nearly as simple as they say.

Well, I figured out what you were telling me. I never did find “My Computer” or “Tools” BUT I did a search for “Folder Options” and found it and I did exactly what you advised. I now do see the extension codes at the end of the files. NOW, what, how do I fix this problem so that I’m able to import music from CD’s I’ve downloaded into my computer and to the Media Player? Now that I see the extension, what next? :confused:

Now that I see the extension, what next?

What are the extensions? If they’re MP3, then your ripping software is taking the high quality WAV music from the CD and downconverting it to lesser quality MP3. That would normally be just OK for listening, but it starts to fall apart if you then want to do something else with the music. MP3 is a terrible production format.

What’s the exact error? Use the clipping tool to screen capture the error and attach it here.

Where did you get your Audacity from? Regular Audacity doesn’t check for the patentability of a sound file.


Well, I don’t know about “clipping” either, so I’ll type here exactly what the message in the box that pops up in Audacity as soon as I try to import a music file from a CD, message box says:
“Audacity attempted to use FFmpeg to import an audio file, but the libraries were not found.
To use FFmpeg import, go to Preferences>Libraries to download or locate the FFmpeg libraries.”
Then I just hit OK to get out of that box message.

I just looked at one of the CD songs I tried and it’s extension is “wma”. Does that help clear the mystery?

Now I am able to import music that I have recorded in real time myself with the Audacity and put in a folder called “Songs” but this was just a few songs I recorded in real time using the record button in Audacity to enable you to record sound from a computer website. These few “Songs” I have there are not the 100’s of CDs I could choose from if I could Import my CD music and these “Songs” are in a separate normal folder I called “Songs” they’re not part of my official “Music” files where all CDs are.

As for where did I get Audacity? I bought a “Wikoo” cassette to Mp3 converter and it came with a mini CD disc that when you put it in your computer CD player it downloaded Audacity. I used my Audacity without a problem transferring my cassette tapes and I can record my voice with a mic on the computer but when trying to import music from CDs it stops me with the message above.

I answered your questions, but I still don’t have an answer to my problem. You wanted to know the extension, it’s .wma . OK, so now how do I import the music from all the CDs with the wma extension, that’s the question? :question:

Well, I don’t know about “clipping” either

Clipping is a Windows built-in program that lets you take a snapshot of your screen or draw a box around a portion of the screen and save that.

Does that help clear the mystery?

It’s a different mystery now. Those are Windows Media Audio files and I’m not shocked that Audacity won’t open them natively.

Jury’s out on whether FFMpeg add-on software will do any better. Windows Media can produce Copy Protected sound files and that may be where your message and failure are coming from.

You may have just sailed straight out of my helping you. I’m typing on a Mac. I stopped using Windows machines when they never seemed to do what I wanted and it was always my fault.

We’ll see if a Windows forum elf drops in to help.


I posted for help. We should remember this is a forum, users helping each other, not a help desk. Audacity has no formal paid help.


Please check which version of Audacity you have (look in “Help > About Audacity”).
If it is not “Audacity 2.3.1”, then download Audacity 2.3.1 via the Audacity website: Audacity ® | Download for Windows
The download that you need is: “Audacity 2.3.1 installer (22.22 MB, includes user manual)”

To upgrade from an older version of Audacity:

  • Run the Audacity installer, and during the installation, look out for the option to “Reset Preferences”.
  • When the installation is complete, Audacity will launch and ask you to confirm that you wish to reset preferences. Confirm and continue.

To support proprietary formats such as WMA, Audacity requires a helper called “FFmpeg”. Follow the instructions here to install FFmpeg:
Note that these instructions are for Audacity 2.3.1.

OK, will do, just checked, it’s 2.1.3 version of Audacity. I suppose this means I should install the 2.3.1 version. In doing this will I be able to import .wma music files? By the way, I did install Lame when I first installed Audacity from the CD and I am able to import .mp3 music files but not .wma files.

And thank you to all who have tried to help. I do realize this is just a volunteer helping situation. You would think Audacity would have Audacity experts here to help answer questions though instead of relying on regular people to volunteer. But I do thank you all.

LAME is used for exporting MP3 files.
Audacity can import MP3 files on it’s own (LAME not needed for importing MP3, only for exporting)

FFmpeg is required for importing or exporting WMA, AAC, AC3, M4A and various other “non-free” audio formats.