I can't hear straight

So I have windows 11 on my laptop. I like to record my podcast, some singing, etc using my scarlet interface. Once i tried it before i had the option to turn the latency off completely because it was hitting my earphone in a delay, so it was like an echo instead of allowing me to hear it in real time. THEN i updated Audacity, it worked PERFECTLY with me hearing myself. I updated a few months back and now it late AGAIN and there is no longer an option to turn it off. I continue to update it but the problem is thill there. No other setting on my PC has changed. So i cannot figure as to why i am not able to fix this.

What should i do? I prefer to have the ability to hear myself as i record with no delay, but am willing to go without it if Absoluty necessary. Please help

You hve your headphones plugged into your Scarlett, right?

Turn off Playthrough.

Edit > Preferences > Recording > Playthrough.


Post back if it works. There are other things that can go wrong.


I will give it a try today. Is there no fix for the latency issue? hearing myself is more ideal but i’ll use what i can

There are two latencies. Recording Latency is the one you set in software so when you sing or play to a backing or rhythm track, your performance comes out in time, neither early or late.

Then there’s machine latency which is the time it takes for your voice to go into the machine, into Audacity, turn around, and come back out. That one is fixed. You’re stuck with it.

However, if, as in my question above, your headphones are plugged into the Scarlett, the Scarlett should be giving you your live voice to your headphones. If Audacity Playthrough is checked by accident, Audacity is also sending your your voice, but late. If you de-select Playthrough, the Scarlett in-time voice should remain.


I’m using it now. I tried unselecting “software playthrough of input” and all i get is like a static and nothing records.

Im not sure why. Nevertheless, on this same pc i used it earlier this year and it worked prefectlly. But since i updated it, it comes out late like echo.

I have not changed any settings on this pc so im not sure whats going on. What are the specs to get the latency to work right? Maybe i can change my settings entirely to see how to make it work

thats another thing, i used to be able to hear my voice when not recording, but since i did the upgrade it stopped doing that. So how do i fix that?

okay, so i can now hear from my headphone, but now i can’t get rid of the software doing the echo latnecy again, i need it to just be off, but like i said it just give me a static wine

Third time:
You have your headphones plugged into the Scarlett, right? Wired Headphones?

Do you use Skype, Zoom, Meetings or any other chat program?

Which Scarlett?


yes wired headphone are plugged into the Focusrite scarlett solo gen 3

Yes i have zoom

Thank you.

Zoom is important because communication programs take over sound services, connections, programs, and pathways when they run and you have nothing to say about it.

Do Not leave any programs like that running in the background while you’re trying to do production. Sometimes, Zoom can close, but still leave its sound changes behind.

It’s desirable to Clean Start your Windows machine before attempting production.

Shift+Shutdown > OK > Wait > Start.

Not regular Shutdown and not Restart. Do not let any programs automatically start when Windows wakes up. This may take longer than normal but that’s Windows closing everything.

Did that help? Did the symptoms change?


Okay. I made sure Zoom wasn’t running in the background. I did the “Clean Start”. Made sure nothing started when windows woke. But, no change.
I even tried removing Zoom from my computer but no change.

OK, now that you know Zoom isn’t in there “helping” you, start with ordinary sound setups and adjustments. See which parts don’t work right, but start simple. Don’t automatically dive into a complicated show and then try to unscramble the results.

Can you make a simple sound recording whether or not you can hear it? Stop. Can you play it back to your headphones? And so on.

You may hit one simple setup that’s not going to work. That’s the one you write down and we’ll see if we can figure out what happened.


This topic was automatically closed after 30 days. New replies are no longer allowed.