I can not install version 2.4.2. [SOLVED]

OS Linux Ununtu Studio 16.04.6 LTS

I can not install version 2.4.2.

Did it build successfully?

I did not understand the question.

Ubuntu Studio 16.04 reached it’s “end of life” on April 25, 2019. It is now obsolete and no longer supported.
Installing Audacity 2.4.2 on Ubuntu 16.04 will be extremely difficult because Ubuntu 16.04 is too old.

Strange, but version 2.4.1 was installed through updates.

How do I install version 2.3.3?

It is easy to build from source. I did it last night on Ubuntu 16.04. You may need to update cmake (see wiki entry) I updated cmake to 3.17.3 and built wxwidgets as in the wiki.


Not through an official Ubuntu update.
Perhaps you can get 2.4.2 from the same place that you got 2.4.1 from. Alternatively you could build Audacity from source as kmod suggested.

Also you can get it on flatpak.

Version 2.4.1 was installed through official updates.

Version 2.4.1 was installed through official updates.

It was from a ppa you added at some point. The official version xenail is 2.1.2


And it works well.

I didn’t add anything specifically. Before upgrading to version 2.4.1, I got version 2.3.3. Then it was updated to 2.4.1.

I’m interested in how to install version 2.3.3, which was before the latest updates.

Here you can get 2.4.1 but it wants to upgrade a lot of other things. So, I suggest activating the ppa, upgrade only audacity and its dependencies (I think maybe only two packages, audacity and audacity-data) and then disable the ppa.

sorry, forget to provide link for ppa

Also there is a flatpak (2.4.2)
google for how to install a flatpak with command line (no integration with software store in Ubuntu16.04)

I want to install version 2.3.3, which was before update 2.4.1. Since version 2.3.3 - it worked very stably on my OS.

Well here you can get 2.3.3 but the the ppa is not published for 16.04. https://launchpad.net/~ubuntuhandbook1/+archive/ubuntu/audacity
So may be you can add it to your sources, then edit the file in /etc/apt/sources.lists.d to find the file for audacity and change xenial to bionic in the file name and edit the file to change xenial main at the end of the ppa’s entry to bionic main and see if you can upgrade (synaptic would be very useful for things like this, just change the audacity line in repositories form xenial main to bionic main)

Do it at your own risk. if something breaks use ppa-purge, but there is a chance that it may not work.
I think there are probably some dependency issues for wxwidgets (there are many files) and that’s why it is not published for Ubuntu 16.04.

If you must have 2.3.3 compiling from source is not difficult, checkout the wiki link I posted. For 2.4.2 you can get a flatpak.

All this is very strange, given that prior to the advent of version 2.4.1, my Audacity has always been successfully updated through updates. And version 2.3.3 was installed through updates and worked perfectly, without problems.

It is not strange at all

Linux Ununtu Studio 16.04.6 LTS is obsolete. It is no longer supported. No one are making updates for 16.04 because it is discontinued. The current version of Ubuntu Studio is 20.04.