Hum when I try to record from vinyl

I was successfully recording my old vinyl records into digital until recently. Now when I try to record I get a very loud hum. As far as I know, I did not change any settings in Audacity, nor did I alter my PC settings. The sound system works as it should for everything else, such as playing songs on iTunes or watching video on youtube. Can anyone share some insight as to what I might try to resolve my problem. Thanks.

Does your turntable or pre-amp have a “ground” / “earth” cable? If so, perhaps it has become detached.
If not, check all of the leads and connections.
Also check that there is no electrical equipment near to the equipment that wasn’t there before.
If you have any lights with dimmer switches, turn them off.

Thanks for the suggestion but I tested the software without having the turntable attached to the PC. I got the hum just the same so I don’t think it’s an issue with the turntable.

I get the hum as soon as I set the software for record. I tried recording anyway, thinking that maybe the hum is only present during recording, like some feature of passing the music through the system. The hum was all I could hear while the record played–no music. And I could see from the graphic display that only the constant hum was recorded.

How is your turntable connected to the computer?

without having the turntable attached to the PC.

Is this a USB turntable? “E-Z Transfer USB Turntables” are not known for high quality or long life. If it is USB, then you don’t have sound cables or special grounding cable. You may have a dead turntable.


Can you [u]attach a short sample[/u] of the hum? …I’m thinking this isn’t normal hum… Usually “hum” refers to 50/60Hz AC power line hum. It’s usually not super-loud, and if gets loud it usually sounds more like a “buzz”.

Have you selected the input you’re using (USB? microphone-in? Line-in?) as your recording device, or have you selected “Stereo Mix”, or “WASAPI loopback”?

Thanks for your support. Based on the responses I checked the input setting. My problem was resolved after I selected the USB audio CODEC option. I don’t know how it might have been altered since my previous recording. I do not get into the nuts and bolts of the software unless compelled to do so. Thanks again to everyone who helped me.