Hum remover.

Who are you talking to?
The “Hum remover” is not an official part of the Audacity project - it is not shipped with Audacity. It is a “third party” plug-in that an Audacity user has shared with the community. If the license says that it is GPL v2, then you are free to modify it and share your “improved” version with the community.

I’ve found the reason! If the effect is applied to the entire track, but not selecting all (1), the speed drops sharply, but if you pre-select the track (2), the effect works absolutely normally, as before. But how can it be? Please correct so that it can be both.
Untitled.png
Capture.PNG

That it’s processing the whole track/project, (which takes a long time), when you mistakenly think it’s processing a short selection.

[ Older versions of Audacity did automatically apply an effect to all of the project if no track selection was made].

Unclear. All other effects, if applied to the whole track, work exactly the same and with the same speed in both cases.
1 Nothing selected
2. Select all
That is, if nothing is selected, the effect is applied to the entire track and everything, and speed, as usual.
But this effect, Hum remover, works differently.

  1. If nothing is selected, it works with the entire track, but for a very long time. And only on a Lenovo laptop, on an HP laptop, it’s normal, like everyone else.
  2. If you select all, it works, naturally, with the whole track, but at normal speed.
    Why, what is its feature?
    Capture.PNG

Looks like you’ve solved the problem.

Does this happen with all projects, or just one specific project?

If it happens with all projects, please give step by step instructions for how to reproduce the issue. (I can’t currently reproduce the issue, and going by the other replies, it seems that no-one else can either.)

Apparently, to reproduce the problem, you need a laptop brand Lenovo, and, preferably, a new one. Then, install Audasity version 2.3.1-alpha-Oct 22 2018, download Hum remover from the Nyquist plug-in page, install, import a track, apply to the entire track, but select nothing, see the execution time.

steve, thank you! I compared Noth filter and Hum remover even earlier, the conclusion is that Hum remover gives the best results. I also noticed that the effect works normally for short, up to 3 minutes tracks, if you take more, even selection doesn’t help.

I’ve purchased a new laptop, this time the brand “Asus” - and the problem was exactly the same!

I’ve downloaded the new version Audacity 2.3.1 - the problem was exactly the same. That is the trouble!

The problem was not solved even in the new version (Audacity 3.0.0) and repeats on different computers. It maybe caused by the graphics driver, on my laptop there’s Intel driver. Please, check this plagin on the laptop with Intel Graphics and try to reproduce the problem somehow. How long! Thank you!

There were some Nyquist issues in 3.0.0 which could have contributed to the issue. Please try this again with the 3.0.2 Release Candidate RC01 here.

Note: Please do not use this release candidate for production work.

If you still have the issue, please post your .WAV file and a link to the Hum remover you are currently using. Then please describe exactly the issue you are experiencing and how it differs from what you are expecting.

All done, Certainty, the problem exactly has repeated. I import mp3-file 2:12 (2 min 12 s) length only. Then I apply to it the set of effects, as built-in, as Nyquist plugins. All of them work at normal speed, work of every effect takes less than 5-7 seconds… Except Hum-remover. It takes more than 1 min, which extremely slows the work down. This looks like somethng’s holding it.The problem lasts many years.((( Please, help get riid of it.
https://wiki.audacityteam.org/wiki/Nyquist_Effect_Plug-ins#Dual_Tape_Decks
I couldn’t appload mp3, too large (4 Mb only - and too largre). Please, let me appload mp3-files not bigger, than 5 Mb, and not 2.
Фото1.jpg
Фото.jpg

  1. I believe you are referring to this link? : Missing features - Audacity Support

  2. MP3 is OK, if you can reproduce the problem with MP3. If the file is too large, post just a sample of it. Or post to a file-sharing site.

  3. Please state all of the parameters you are using so that someone may try to duplicate your issue. For example: 50Hz or 60Hz?, etc. Are you using all of the defaults?

  4. Please describe exactly the issue you are experiencing and how it differs from what you are expecting.

How long is that track?

What settings?

Hi! Track lenth is 2 min 12 sec. What is this nonsense?
Фото1.jpg

Settings. Although, the problem repeats regardless of settings. Like strong brakes (Did you take Russian trains?).
Фото.jpg

It worked on my machine, but I’m on Linux.
It was quite slow with those settings - about 36 seconds.

But it’s very slow. For example, “Normalize” take less than 1 sec, “Change speed” - about 1 sec, and by the same token all the others.