how to uninstall

I keep reading things that say drag the icon to trash. But when i do that a bubble comes up that says “audacity cannot be deleted”. And someone tell me how to uninstall? Thanks

Are you trying to use it at the time or is it open?

Are you an administrator on your computer?

Apple (upper left) > System Preferences > Users and Groups > Kozikowski (admin), [X] allow user to administer this computer.

That’s what mine says.


it is not open. i closed it. and this is my personal computer so yes i am the administrator.

Did you look down that pathway to check?

yes, it says i am the admin. the box for admin is checked, although it is not “active” as in i can’t uncheck it

also it does not show up in my applications–it shows up in my “devices”

OK. That’s normal. You need password access to change that panel. It’s a dangerous panel to leave open.

Go > Applications > Control-Click on the Audacity folder > Move To Trash.

Did that work? Does your Application folder look something like that attached? I have two Audacity installs, but the “normal” one should work like yours.

Screen Shot 2014-06-05 at 7.10.28 PM.png

There is an audacity file in my applications folder that i can move to trash. then when i try to delete it , it says it can’t because it’s in use. but i do not have audacity open. i closed the program and the icon does not show in my toolbar. however, even after deleting the audacity application (which does not have the icon, by the way) it still remains in my finder as a “device”. when i try to move that icon to trash it tells me it can’t delete it.

oh and , no, my applications does not look like yours. it does not list things as words, it opens a window where you have pictures of each icon associated with the application

is there a way i can show you a screen shot of how it looks in the trash? i took one but don’tknow how to put it here

The line of icons above the contents listing should let you change the view. You probably have the first icon selected — big icons. I use the second since I’m more used to the Windows/Linux/DOS text view.

You can take a picture of the whole screen with Shift-Command-3. There are no options. You can press Shift-Command-4 and draw a box around a portion of the screen you want to send. The tools save a picture on my desktop.

Then, scroll down from the Audacity text entry windows on the forum until it says “Upload Attachment.” Follow the instructions.


You should have an Audacity folder in Applications, not a single file. And, it’s a given none of this should show up under Devices.


i know how to take a screen shot==i don’t know how to post it here. and it may be a given that none of this should be in my devices but it is. that is where the file exists. so how do i uninstall it? it is causing problems when i upload photos

i am attaching how it looks in my trash when i put what was in applications there. however, it cannot be deleted from trash–says it is in use. it also is in my devices as i said and cannot be moved from there.
Screen Shot 2014-06-05 at 10.21.27 PM.jpg

I think it’s time to restart the machine. I think there’s a few too many blue activity markers in your dock. Audacity doesn’t like playing with others. If you have multiple applications standing on the sound services, there could be conflicts. There are probably conflicts.


How are you looking at “Devices?”

When you installed Audacity, you (probably) downloaded a “dmg” (disk image). Double click the dmg and it will explode into a mounted drive with the Audacity folder in it. Drag the folder into /Applications. Run Audacity from inside that folder or drag the Audacity application to the dock.

Delete the dmg and drive.

If you tried to run Audacity from inside the mounted drive or the dmg, it doesn’t work right. You shouldn’t drag either one into /Applications, either.


i think it may be solved. i did turn off my computer last night and the trash let me delete the audacity thing in there. and it is not showing up in my devices now. so hopefully it is gone. i will see if it pops up anywhere else. thanks so much for putting so much time and thought into this. i appreciate it.

You can’t delete the DMG if it is still mounted (that is, listed under “Devices”).


Where is this “Devices” of which you speak?


Open Finder.

Double-click a DMG to mount it.

Notice the DMG has appeared in the Finder Sidebar on the left, in a “Devices” section underneath “Favourites”.

Now right-click on the DMG in the list in the Finder window, and choose “Move to Trash”.

Open the Trash and empty it. Mac declines to do that because the DMG is in use.

Right-click over the DMG under Devices and choose “Eject” then you can empty the Trash.

You can CONTROL-click if your mouse has only one button.

If you don’t see Devices in the Sidebar, Finder > Preferences… and enable “CDs, DVDs, and iPods” in the Sidebar list.